Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

It won't connect to certain free official public networks in shopping malls, caffees or hospitals for example where it supposed to even with signal strength bars being 3-4. That's right gentlemen, almost full signal strength and it just stalls stating it is aquiring IP address but after a few minutes disconnects. I have this network connectivity log if it can help, otherwise guide me to the right direction and I will supply you with required logs.

03-19 13:12:22.351 I/wpa_supplicant( 8091): got scan complete 
03-19 13:12:22.351 I/wpa_supplicant( 8091): wpa_supplicant_get_scan_results:return scan results2 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[AndroidAP],rssi[-83],BSSID=b4:07:f9:4c:b8:c1 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[bneizion],rssi[-59],BSSID=1c:af:f7:7d:f6:d9 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[],rssi[-67],BSSID=00:15:70:d1:60:ac 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[],rssi[-73],BSSID=00:15:70:5f:f8:b4 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[orange-TSZQ],rssi[-86],BSSID=00:21:04:db:fe:42 
03-19 13:12:22.351 I/wpa_supplicant( 8091): AP:ssid[zerbrachot],rssi[-73],BSSID=00:16:e3:f0:9f:39 
03-19 13:12:22.351 I/wpa_supplicant( 8091): Received 1400 bytes of scan results (6 BSSes) 
03-19 13:12:22.351 I/wpa_supplicant( 8091): wpa_driver_wext_get_scan_results--- 
03-19 13:12:22.381 D/GpsLocationProvider( 1344): GetGpsInterface+ 
03-19 13:12:22.381 D/GpsLocationProvider( 1344): GetGpsInterface- 
03-19 13:12:22.381 D/lib_locapi( 1344): loc_eng_inject_location, accuracy = 209.0 
03-19 13:12:22.411 D/AutoSetting( 4710): service - mLocationListener: onLocationChanged() location = Location[mProvider=network,mTime=1332155542386,mInfo=244.94112160000003333295.25668425,mAccuracy=209.0 
03-19 13:12:22.441 D/AutoSetting( 4710): service - handleMessage() incoming message, what:1 
03-19 13:12:22.441 D/AutoSetting( 4710): service - mLocationListener: onLocationChanged() location = Location[mProvider=network,mTime=1332155542386,mInfo=244.94112160000003333295.25668425,mAccuracy=209.0 
03-19 13:12:22.441 D/AutoSetting( 4710): Util - isSetupWizardCompleted(): true 
03-19 13:12:22.441 D/AutoSetting( 4710): Util - wifi connected 
03-19 13:12:22.441 D/AutoSetting( 4710): service - processLocationBundle() distance to current is less than 1000.0m, bypass update 
03-19 13:12:22.441 D/AutoSetting( 4710): service - handleMessage() within range 
share|improve this question
    
Is it all or just some public hotspots? And which ones and where are they? –  Liam W May 11 '12 at 16:10
    
All are free public hotpots. –  Boris_yo May 12 '12 at 7:13
add comment

5 Answers 5

If your phone is waiting for an IP address, then your WiFi is connected. And the third last row in your log seems to confirm this status:

03-19 13:12:22.441 D/AutoSetting( 4710): Util - wifi connected

If you can't get a valid IP address, then:

  1. the network doesn't have a DHCP server
  2. the network has been explicitly instructed not to give IP addresses to everybody (a whitelist)
  3. your WiFi lost a DHCPOFFER packet so it's not able to go on with the negotiation

The interesting part of the third case is that it's not necessary for the signal strength of the network to be excessively low. I suspect that also the implementation of the network components has its role in such cases. For example, I recently had lots of issues setting up a temporary WPA2 network using hostap on my home computer. My Android phone simply refused to get an IP address more than half of the times. Whatching my DHCPserver logs I noticed that the negotiation procedure stopped just because my phone stopped answering packets in the middle of the negotiation for apparently no reason. Well, I didn't investigate further the problem (too much time lost with it) but now I know that there are really many things that can go wrong setting up a WPA network.

share|improve this answer
    
Or maybe you have a save a static IP in your phone, so you can't connect with this IP in the network because it isn't free. –  Guillaume May 16 '12 at 15:49
    
I think if it was laptop i was connecting with, it wouldn't fail. –  Boris_yo May 22 '12 at 6:34
add comment

A possibility is that the network is in range, but not strong enough to be connected to.

I get this occasionally on my device - I can see the wifi hotspot in the settings menu, and attempt to connect to it, but it just stays stuck on 'Connecting' for a while, and then gives up.

I attributed this to the network signal not being strong enough, as if I moved closer to the router, it would connect.

share|improve this answer
add comment

Some custom ROMs have problems with displaying the correct MAC addresses.. atleast my CM7 ROM has this problem that makes it troublesome to connect to wifi.

Try to investigate on that matter.

share|improve this answer
    
I have stock ROM now updated to Android 2.3.5 with HTC Sense updated to version 3.0 –  Boris_yo May 12 '12 at 7:11
add comment

Certain public networks have their own firewall to protect the network. Some are password protected with encryption. Wi-Fi has its own limit and boundaries. To connect to public networks it needs its access permission.

share|improve this answer
add comment

Many public WiFi hotspots require a user to log in via a web page. Sometimes, there's a trial offer like for 30 minutes after which one might need to pay for extended use etc.

It's best that you enquire with the tech support / help desk of the mall/airport / organization that provides the access.

UPDATE: Also, in case the hotspots are configured as Ad-Hoc networks, android devices by default don't connect. There are some ways around this though. Depends on your phone and OS and of course, one needs to be rooted.

share|improve this answer
    
He'd still get network connectivity then, just no internet access. –  Erik May 6 '12 at 9:13
    
True. I mistakenly thought he was connected, yet unable to surf. –  Sparx May 6 '12 at 9:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.