Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am having a little bit of a hard time with my new android phone for the reason that it doesnt always connect to certain services (such as Angry Words, or Whatsapp). Sometimes I get the message "unable to connect", when I am using a fairly good network provider and strong enough wifi when at the office.

What I've noticed is that the 3G sign keeps changing to H every now and then. I dont know if that is the issue. Anyway, how can I make the phone only use the high-speed 3G service and why is that that even with strong wifi signal it is giving me a hard time?

Note: Wifi is turned off all the time I am not at home or at the office.

share|improve this question
1  
H should mean HSPA+, which is good. I'd guess that you have the same Wi-Fi problem as me: android.stackexchange.com/q/14162/1465. You can try the app posted there, it helps a little bit, but I think your best bet is just to shut off Wi-Fi. –  Matthew Read May 7 '12 at 22:25
    
@MatthewRead Thanks Matthew. I've just read the other entry on this issue, but I am not sure that is the solution. First of all, I must tell you that I hardly know anything about networking. The other thing is that I need to use wifi connection, otherwise I'll reach my data limit in no time with my network provider and I'll have to pay extra. Anyway, I am not sure what is causing the problem and I am clueless how to go on and fix it. –  Elysium May 8 '12 at 8:24
    
Right. Well you can try toggling Wi-Fi off and on when you get the error and see if it helps, which is annoying but I'm not sure there's many other options. –  Matthew Read May 8 '12 at 15:55
    
@MatthewRead I am actually beginning to realize that in many areas where I go to work (I am always on the move), network coverage isn't that good and on the other hand many applications seem to be buggy. Whatsapp server seems to be offline many times. Angry words server seems to be a bit dodgy too. I mean you guys might disagree, but that what personal experience makes me believe. –  Elysium May 8 '12 at 21:20
    
If you're running Gingerbread or above you might want to check with your battery stats: From the homescreen, menu-key ->setup->device info->battery has a little graphic at the top. Touch this to enlarge. Now take a look at the phone column: red areas stand for "no network", yellow for "low network quality", and the darker the green the better. So if one day you've got a lot of problems, and it's all red-and-yellow there -- you can tell why. –  Izzy Aug 14 '12 at 10:55
add comment

1 Answer

I was in trouble getting my 3G to work, and I did these steps, that solved my problem:

  1. Go to the dialer and type *#*#4636#*#*
  2. Tap "Phone info"
  3. Scroll down, you will see GSM selected;
  4. Open the list and select WCDMA only;
  5. Turn the radio off and turn it on again (there's a button for that on the screen)
  6. Press Home Button, not back button

If you still can't get 3G, reboot your phone and that's it ;)

Enjoy! :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.