Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Every time I plug in my earphones into my HTC Desire S, it starts calling the last dialed number automatically and starts the music after short interval. Does anyone know about this problem?

share|improve this question
    
It sounds like some hardware issue. Does your earphone have music controlls? Is the behavior the same with different earphones? –  Richard Borcsik May 8 '12 at 15:31
    
I plugged my earphone to some other HTC phone and this was not happening..Is it issue with the phone? –  Raghav May 8 '12 at 15:35
2  
Does your earphone have music controlls? Is the behavior the same with different earphones? –  Richard Borcsik May 8 '12 at 15:45
    
Check out the default launch application when you plug a hardware like earphone to your device. Some phones has this option. Check out the music player setting which started the playing music when you connect the earphone and also check the setting of the calls. –  avirk May 9 '12 at 3:28

5 Answers 5

I had the Same issue on my Evo 3d, I downloaded an app called headset blocker that disabled the phones headset remote abilities. This solved the problem immediately.

share|improve this answer

HTC Desire HD Android 2.3.5

I had exactly the same problem, would plug in standard headphones/ earphones/ aux cable to speakers... all of these would register on the phone as earphones with a mic built in for some reason. it would cut music tracks short and play the next one or start ringing a call.

strangely, as i was searching for this thread, the problem has self corrected. All that is different is that I updated ALL of my apps on google app store today. This is the only factor that I have changed. Try this! I hope it works out for you as well as I know how frustrating it was!

best wishes

share|improve this answer

I have this same issue with my HTC desire. My hypothesis is that my headphones or jack have a slight short and is activating the voice commands via the input channel. I am trying to see if there is a way to turn off voice commands on the headphone jack itself or all together without turning off the input channel so I can still use a headphone with a mic for phone calls.

share|improve this answer

Headset Blocker solved this problem for me - no more annoying auto voice commands or auto dials. I was on the verge of buying a bluetooth headset, but the app saved me.

Try HTC Headset Fix also.

share|improve this answer

Download Headset Blocker. Worked fine on my Desire HD.

share|improve this answer
1  
linky is not enough to warrant this answer, a bit more information needed for benefit of others :) –  t0mm13b Jan 3 '13 at 17:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.