Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I'm partially unable to get geolocation within a web browser. When the phone-wide "use wifi for location" box is unchecked, going to a new website the requires geolocation fails. For example, maps.google.com gives the the error "Your location could not be determined." When I check the box, I get the permission request dialog, and after that, I can get geolocation regardless of the "wifi geolocation" option.

  • The GPS works fine, and the Maps app works fine.
  • I have enabled geolocation in the browser settings.
  • I have tried this with the stock browser, Dolphin, and a custom app with a WebView (with the appropriate permissions set up). I get the same result on all three. I also got the same result using the Android emulator on my PC.
  • The phone does not have a cellular plan.
  • Android 2.2 on a Motorola Droid

At this point, I have a workaround, but does anyone have clues about what's going on?

share|improve this question
    
Have you installed Permission Fix app? –  Sachin Shekhar May 13 '12 at 7:16
    
No, I have not. –  Steven Bell May 23 '12 at 1:59
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.