Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

A week ago, I flashed my Nexus S 4g with a custom kernel (Matrix) and ROM (CWM9). On reboot, my NS4G always bootloops, stuck on bootloader loading screen, and never gets to the Android System. It had the same result when I tried to flash it back to a stock ROM.

I removed the battery, put it again and tried to boot into recovery to use adb to check my SD card content with parted (I think there was a problem on partition). In parted I can reformat it using adb or recovery, but its content couldn't be changed. I think there was a problem with NAND flash.

Is there any way that I could Reformat NAND flash to fresh state?

share|improve this question

closed as too localized by Zuul, Al E., Izzy, Ryan Conrad, roxan Sep 14 '12 at 11:14

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Can you try restoring stock firmware & see if the problem persists? If so, turn the phone in for warranty. If not, it's an issue with the ROM. –  Broam May 14 '12 at 15:51
    
since I dont bought it on my country, they wouldn't check/fix my phone. :( no, I can't restoring stock firmware... :( –  andikurnia May 15 '12 at 6:51
    
Stock firmware is available from Google: developers.google.com/android/nexus/images –  Broam May 20 '12 at 15:04
    
also, make sure you wipe the cache and system between flashing ROMS. –  jlehenbauer Jun 27 '12 at 16:06
    
it's been a while. Since I dont know what happen here, I sold it to a friend. Case Closed... :) –  andikurnia Jul 18 '12 at 14:28