Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Every time I try to send a Multimedia message using Go Sms Pro, I get a toast message saying: "Can't send message right now. There are too many unsent multimedia messages"

toast message

This doesn't happen when I send something through gomms (which is really only good for sending to other people with smartphones), and it doesn't happen when I use any other sms/mms client (like handcent or the default sms client). It only happens when trying to send an MMS message with Go SMS pro.

How can I get this to work? I would have thought that if this was a global bug issue, that it would have been fixed by now, so I am guessing that there is something I need to set/reset. What do I do to fix this?

share|improve this question

This has happened to me at least once before. Very annoying. In my case I had to check every thread, and scroll up to look for failed mms messages in the thread(red !). Once one fails, apparently nothing else except regular txt will go through until the offender is deleted for some reason. I think I narrowed it down to a message I sent from my garage. With the doors shut and if I'm in the back, I get one signal bar if I don't move. I think I attached a pic, hit send, then stuck it in my pocket while it was trying to send. Why it doesn't send later when i get a better signal is beyond me. But, by checking all my threads, and deleteing each one the had a red ! eventually I was able to send the one I really needed to send. If it happens again, I'll update the post with more solid information. Phone is G'zOne Commando, Android version 2.3.3 hope this helps someone.

share|improve this answer

In GO SMS you can also:

  1. Click the menu button
  2. Click folders
  3. Go the the outbox folder
  4. Delete all the failed messages there

Worked for me - this was driving me crazy!

share|improve this answer
up vote 0 down vote accepted

I figured it out myself. Here's how I fixed it:

As it turns out, the message that says "Too many unsent multimedia messages" actually means that there are too many unset multimedia messages (who would have thought it!).

I went into the stock message client (the one that came with the phone), clicked the menu button, and selected the "unsent" menu tab. Then I clicked the menu button again, and selected the "delete" tab. Then I just deleted all of the unsent messages.

Now it works fine. Not sure why there was a limit on how many unsent messages there could be, and I'm still not sure why it worked with the stock client, and handcent, but not go sms, but, now it works!

share|improve this answer

I have a note 3 and had the same issues.

  1. Go in your settings and check to make sure sms is your default.
  2. Under the sms program is a setting to make sms your default as well.
  3. Your default notification on your phone system needs to be turned off so that you don't have multiple notifications.

Hope this helps.

share|improve this answer

protected by Community Mar 23 at 23:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.