Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I first got my Droid Bionic, if I pressed the power button on the top it would lock the screen; pressing it again would display the keyguard, requiring me to slide to unlock. I had it configured so that if I pressed the power button in less than 5 minutes from the time the screen went off, I got the keygoard and then was able to use my phone. If I pressed the power button after 5 minutes past when the screen turned off, I had to enter my PIN.

On my new Samsung Galaxy SIII, the behavior is not the same. It's acting like my Bionic did for a short period, which was resolved by updating the Bionic to Android v1.4.2: If I press the power button less than 5 minutes after the screen turns off, then I am right into the phone, with no keyguard and susceptible to pocket dialing or deleting.

The behavior I want is:

  • Power button turns the screen off
  • If the screen is off for less than 5 minutes, power button activates the "swipe to unlock" screen
  • If the screen is off for more than 5 minutes, power button requires a PIN to access the phone
  • If the screen is off, something should be required to get back into the phone, either "swipe to unlock" or a PIN. I should never be able to get back to the last app/homescreen without doing one or the other (or both) to prevent pocket dials or accidental UI actions.

Settings I currently have set under Settings > Lock Screen:

  • Screen Lock: Secured with PIN
  • With Swipe Lock: Enabled
  • Lock Automatically: 5 Minutes
  • Lock instantly with power key: Off (On requires PIN immediately after power key. I want the swipe, and PIN after 5 minutes)

How can I restore the functionality where the keyguard (swipe to unlock) activates instantly but the PIN lock activates only after 5 minutes?

share|improve this question
    
Obviously something has disabled the key locking mechanism - do you know what app was it you installed prior to the key lock getting messed up? –  t0mm13b Aug 23 '12 at 20:23
    
@t0mm13b No, sadly I don't! Maybe I just have to uninstall one by one. UG. –  Josh Aug 23 '12 at 20:26
    
There must be an app that has the permission "android.permission.DISABLE_KEYGUARD" in their AndroidManifest.xml that you unwittingly installed somewhere. –  t0mm13b Aug 23 '12 at 20:49
    
@t0mm13b If you know a way I can find that (I have SSH access but not rooted) please do answer! –  Josh Aug 23 '12 at 20:56
add comment

5 Answers

This function is also referred to as the "keyguard." Most of the phones that I have had do not allow you to toggle this on and off in the settings. Clearly something, possibly another app, toggled this off. I use Tasker to manipulate this setting. You may need to be rooted to do this but you can enable or disable they keyguard manually or programatically. There are also third party apps for toggling the keyguard. They are usually advertised as ways to disable the keyguard but they slice both ways. Depending on what disabled your keyguard in the first place, you may only need to use this solution once.

share|improve this answer
    
Hmmm... I'd prefer a solution which doesn't cost $6.50, but if there's nothing better I can ry this. –  Josh Aug 23 '12 at 15:50
    
+1 for the proper term "keyguard" -- searching google for "android toggle keyguard" led me to MyLock which has intermittently resolved this issue... I suspect some app I have is activly trying to disable the keyguard... –  Josh Aug 23 '12 at 15:59
add comment

I'm not fully sure if this is what you want, but you might want to enable the setting "Power button instantly locks" setting in the security section of the preferences. (That's where it is in ICS, I assume name and location are similar in Gingerbread.)

share|improve this answer
    
My new phone has this, but sadly that requires the PIN immediately after lock. I want the keyguard (swipe to unlock) after pressing the power button, and the PIN only after 5 minutes. –  Josh Oct 9 '13 at 15:24
add comment

Its called "Set up screen lock".

You can find it under Settings -> Security -> Set Up Screen Lock

You'll want to change it to slide.

share|improve this answer
1  
This is already set to "Numeric Pin" -- the issue is when I press the lock button on my phone, the swipe lock is not activated. I have tried changing it here and it does not take effect. –  Josh Aug 23 '12 at 15:47
add comment

Right, the best you can do is download this app called 'aSpotCat' from the Google play store.

This will iterate through your listing of apps installed on your device.

To carry out the task -

  • Tap on 'aSpotCat' that is the app that was downloaded from the Google Play store.
  • Tap on 'List apps by permission'
  • Tap on 'System tools', this will expand, and there will be a button called 'Details', tap that.
  • Scroll down to see 'Disable Keyguard', tap on the arrow beside it, and it will expand itself, in there, you will see apps that have the permission to do so.

This will help you track it down and there should be an app listed in there responsible for disabling the keyguard, uninstall it and fingers crossed it will resolve it!

share|improve this answer
    
Awesome handy tool to have! Checking this out now... –  Josh Aug 23 '12 at 21:12
    
OK, I had a number of apps capable of disabling screen lock. Simply uninstalling them didn't fix the issue, but let's see if a reboot will... –  Josh Aug 23 '12 at 22:13
    
Sadly, not. Unless it's a built in app which I can't remove. I was really hopeful this would work. I guess I'll have to wait for the ICS update and see if that fixes it. +1 for aSpotCat though, that's awesome! –  Josh Aug 23 '12 at 22:20
add comment

Same issue for me.

Solved removing last "Maps" app update. Found it using "aspotcat", like t0mm13b said.

share|improve this answer
    
HA! That's one of the few apps I didn't remove! –  Josh Aug 24 '12 at 20:43
    
Sadly this didn't work for me. Did the problem go away immediately after removing the maps update? Did you have other apps with the Disable Keyguard permission or was Maps the only one? –  Josh Aug 25 '12 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.