Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a brand new ASUS Transformer Prime tablet running ICS which I have been using for the first time over the last few days.

I can access the internet without issue using the email, Gmail, browser, YouTube apps, but not Google Play. When I try to use the Google Play Store app it shows a "loading..." message for a few minutes and then stops with a "No Connection" message.

Any ideas how I can fix this?

share|improve this question

2 Answers 2

I was on the verge of packing the tablet up and returning it to Amazon and thought I would try one last thing. I took the tablet to a friends house and tried it on their WIFI just to double check it was not my network. The table worked first time and I used Google Play to install a number of apps.

I then took the tablet back to my house and Google Play continued to work and I installed some more apps.

I have no idea what my router was blocking that prevented Google Play from working but it seems fine now. If the problem returns I know the issue is with my router now, not the tablet.

share|improve this answer
    
Note that the market in your device is actually an application trying to connect to a distant service in a certain why, while the internet simply loads web pages if a connection is found. I personally get the same issue you've described a lot so when it happens I just switch to G3 instead and it works. so it may just be an issue with the market app. –  svarog Jun 28 '12 at 8:43

I am also using a ASUS Transformer Prime tablet but the Play runs very well in that. I would suggest the following,

  1. Restart the tablet.
  2. Try to charge for atleast 8 hours

Also did u install the latest firmware that is being provided by ASUS, that firmware is a bug filled update. Do not update that. If you have updated it then it could be because of that.

share|improve this answer
1  
What does charging have to do with this? –  Richard Borcsik May 29 '12 at 8:30
    
Sometime due to poor battery the tab is not able to connect properly to the Wifi or the 3G/4G data connection. (My own experience) –  Sam007 May 29 '12 at 16:05
    
And it takes 8 hours to charge it up? –  Richard Borcsik May 29 '12 at 16:32
    
8 hours is generic time that I wrote since that is the time duration one should charge when they take their device out of the box. So 8 hours completely saturates the battery. –  Sam007 May 29 '12 at 16:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.