Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

With (or without) my USB keyboard attached... my tablet will sleep after 1 minute of no activity, or if I manually make it sleep by tapping the power button. However, with my keyboard attached it will wake the tablet again after 30+ seconds. And it will continue to do this sleep..wake..sleep..wake.. until I disconnect the keyboard.

Is there any way to prevent the keyboard from waking the device?

Just to add... if the tablet was already sleeping when I connect the USB keyboard, then the tablet will still wake up after a short period of time. (It is not just when the tablet sleeps having been using the keyboard.) The lights on the keyboard flash just before the tablet wakes up, as if the tablet has sent the signal to 'wake up'?

The only related setting I can find is "Stay awake - Screen will never sleep while charging" (not selected) under Developer options.

EDIT: The tablet is a DGM T-703 7inch - a very generic/vanilla tablet AFAIK. The keyboard is an Afunta(TM) Artificial Leather Keyboard Case, but I have tried another standard USB keyboard and the same thing happens.

share|improve this question
    
What tablet and keyboard are you using? –  Bryan Denny May 24 '12 at 13:10
    
The tablet is a DGM T-703 7inch - a very generic/vanilla tablet AFAIK. The keyboard is an Afunta(TM) Artificial Leather Keyboard Case, but I have tried another standard USB keyboard and the same thing happens. –  w3d May 24 '12 at 13:38
    
Does the tablet support any other USB devices? I'm not really familiar with USB support on Android as I've never used it. If it does support other USB devices, does it have the same behavior if those other USB devices are plugged in or only the keyboard? –  Bryan Denny May 24 '12 at 17:39
    
I can connect a USB memory stick, but this is OK (it allows the device to go to sleep and it stays asleep). I can also connect it to another PC to transfer files, which also charges the device, but again this is OK. Only the keyboard seems to be an issue. –  w3d May 24 '12 at 18:58
add comment

3 Answers 3

I now have the same issue using a 7" Sumvison Astro+ after updating the firmware to the manufactures latest ICS listed version. From what i can tell this issue has been introduced as it wasn't present when i first received the tablet with the original firmware.

The details the device lists are

Android version 4.0.3 build version 9F2-D1-H2-H01-2102.20120515 baseband version 1.1 Kernel version 3.0.8+

The release notes list nothing but stability improvements so no clues as to what has been tinkered with. Generally the update was successful a Wi-fi issue i had with streaming music has been cleared and the devices has had it's default CPU speed bumped up which makes it feel snappier, if this keyboard issue wasn't there it would be perfect.

share|improve this answer
    
Thanks for the feedback. I'm not alone! My tablet (7" DGM T-703) would seem to be very similar spec to yours, and the version numbers all match (build number is slightly different... 97F2-R1-H1-H01-1899.20120401). –  w3d Jun 12 '12 at 13:48
add comment

I also have the same issue on an 7" Astro+ - BUT Also there is no "People" (Contacts) App - although it shows in Settings on the Apps list, is cannot be found as an Icon anywhere...

Anyone else got this as well?

share|improve this answer
add comment

Here is a solution! You need to enable screen PIN/password lock. It will disable the physical keyboard in sleep mode. :)

share|improve this answer
    
This is not an answer to the question. If you have the same problem, please wait for an answer. If not, create a new question, if you do not find any answer by doing a search. –  geffchang Feb 19 '13 at 15:46
2  
OK so I did find a solution! You need to enable screen PIN/password lock. It will disable the physical keyboard in sleep mode. :) –  jenna Feb 19 '13 at 16:03
    
You can always edit your own answer, by the way (that's in fact the intended way to improve the quality here) :-) –  ce4 Feb 19 '13 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.