Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Got my Samsung Galaxy Ace a few days ago. Been working properly till yesterday when something strange started happening. Whenever I select the Clock application, the application starts, I see my clock for a brief moment (like a second) and then the phone locks. When I unlock it, it returns to Clock app and then immediately locks again! This keeps happening, not even giving me time to return to the home screen.

If I reboot the phone then it returns to the home screen and it works properly till I select the Clock application again. Then the same story happens and repeats.

So basically once I select the Clock application, the phone will lock. My phone OS is Android 2.3 Gingerbread. Can't figure why this happens. Any help would be appreciated.

share|improve this question
Have you installed an app recently? The general consensus in troubleshooting is to check if you installed an app/widget from google play first, if not, then the second question is, did you play with something that caused it without knowing/understanding about it? – t0mm13b Jun 26 '12 at 15:43
sounds like it's crashing on start, does it go black screen and shows you an error dialog ? – svarog Jun 26 '12 at 19:15
Have you tried deleting data of the clock app? Enter settings then go to Applications then Manage Applications. From there you have to select the All tab and then find the clock app. There should be a Clear Data button. Just bear in mind that all your data and possibly alarms will be included. – Arvanitis Christos Jun 26 '12 at 21:25

I had the same problem, and solved it by simply re-setting the "Screen timeout" option in display settings. It seems some app messed it up.

share|improve this answer

protected by Community Dec 6 '12 at 13:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.