Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my HTC Desire phone I use a chess website. One of the links on that website opens a popup window displaying a chess board and other items. On my PC it opens in a new tab of my browser, that is fine.

However, when accessed on my HTC Desire handset instead of opening in a new window accessible from the Menu --> Windows section it opens in a framed overlay on top of the current screen.

I’d prefer it to open in a full-blown Window if possible as I’m losing a little bit of screen real-estate with this overlay. Is there any way to disable this feature?

Rob

share|improve this question
    
Does it do this on any other browser? Chrome, Firefox, Dolphin, etc.? –  Bryan Denny Jun 6 '12 at 14:09
    
This could simply be the mobile version of the website. Try selecting the option from the Options menu... "Request desktop site". –  w3d Jun 6 '12 at 14:28
    
@ w3d - I'm pretty sure it's not the mobile version of the site as the appearance is quite different ( I used to use that site on my old phone) . I will double check though. @Bryan Denny - I haven't tried with any other browsers other than the stock browser. The phone is really tight on storage space so I don't really have room to have an extra browser app installed to clear this annoyance. –  Rob Jun 6 '12 at 15:05
    
What browser do you use on the desktop/PC? Is it possible that your desktop browser is configured to always open new tabs rather than windows (although that should still open a window on the mobile browser)?! Is JavaScript disabled on the desktop?? –  w3d Jun 6 '12 at 16:23
    
I use Firefox on my desktop PC's . I do have Tab Mix Plus installed which I think diverts new windows into their own tabs.<br/><br/> Is this how it /should/ be appearing on the android browser then, i.e. the default behaviour is to use this overlay? –  Rob Jun 6 '12 at 16:38
show 2 more comments

1 Answer

up vote 3 down vote accepted

Those "Analyze Board" links are coded to open a popup window using JavaScript. Your desktop browser (using an extension) is overriding this default behaviour it would seem, in order to open in a new tab instead.

Those links are not programmed in a particularly accessible way unfortunately - if you don't have JavaScript enabled you get nothing. Under Google Chrome on the desktop for instance I cannot avoid opening a popup window, it simply doesn't work if I choose to open the link in a new tab (I get a blank page).

Having said that, using the default browser on Android 4.0, does open a new tab when those links are clicked - I don't get a floating popup window.

I would have said that the problem is a combination of the website (not being accessible) and of the default browser on your mobile that is unfortunately unable to deal with this situation. Can popup windows be controlled in the browser settings? In some cases you could disable JavaScript on the mobile to get around this, but on this website if you did that you would get nothing!

EDIT: You mention that you don't have much room on your device to install an additional (full blown) browser. Have you considered perhaps Opera Mini (858KB) or Dolphin Mini (1,014KB) - these have a reduced storage footprint.

share|improve this answer
    
Thanks for the information. I'm shortly due to be getting a new Android phone ( HTC Sensation XE) which runs ICS so perhaps the default behaviour will be better or failing that I should have more space for an alternative browser. –  Rob Jun 7 '12 at 8:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.