Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

The low disk space notification frequently comes up. I can't get rid of it; the clear button doesn't clear it, and neither does tapping it. It's just taking up space. How can I get rid of it?

I've got 20 MB of free space on my phone, which isn't a lot, but it's sufficient. I already know how much space is available, so a constant reminder serves no purpose, as there's nothing I'm willing to delete to free up space.

This is a Google/HTC Nexus One running Android 4.0. (Quite an old phone to be running ICS, but it was like that when I aquired it secondhand.)

Edits in response to the comments and answers:

  • I've already moved all possible apps to the SD card, and even a few that weren't supposed to be moved there. Unfortunately, Android insists on keeping some stuff on the phone, even when the apps are moved off. As a Linux user, I can't understand this. By a combination of choosing the $PATH well and manipulating mount points and symlinks appropriately, I can't see why it should make any difference to the system where the app is installed.

  • I've already cleared the cache. There's not much there, since I've been aggressive in my cache management. I've even cleared out several apps' data.

  • I haven't yet gotten around to moving my data to the SD card, as I asked about here. I think it'll only amount to a few MB of savings, though.

share|improve this question
    
Can you move apps to the SD Card? That may be your best bet. There are a few other suggestions in my answer to a similar question. –  gary Jun 7 '12 at 12:26
    
Unfortunately, there is no way that I know of to get rid of the message except to clean up space :/ –  Bryan Denny Jun 7 '12 at 13:40
    
Just as an aside, Android won't let you keep some stuff on the external SD because (1) it's removable and (2) it's FAT32 and so file permissions are an issue. –  Logos Jun 7 '12 at 20:40
    
Yes, I have the same annoying problem, 148MB free, yet the phone says low disk space so it won't let me download a half dozen text only emails on Gmail, what a joke this OS is... –  Kmeixner Nov 21 '13 at 19:40

4 Answers 4

up vote 2 down vote accepted

It is enormously annoying, isn't it? There's no way to suppress it on an unmodified system that I know of, but you can at least free up more internal disk space by emptying system and app caches using an app like SD Maid or by going into the application management section (Settings->Applications->Manage Applications->All, then click on an app name) and manually clearing out app data for hogs like Google Maps and the like using the Clear cache button (note: don't clear the app data! just the cache).

share|improve this answer
    
Thanks for your answer. I've added additional details to my question, but they probably won't change your answer. –  Scott Severance Jun 7 '12 at 15:21

Check out Visual Voicemail Plus by PhoneFusion. I found a setting in the app under "Notifications and Sound", called "Disable space warning". Kind of weird that a Voicemail app has this function, but it's awesome! Also, you can disable "SDCard not found" notifications and enable an "Ignore carrier voicemail" option, for those who use Google Voice.

The "Plus" version is free to use, but it does require registration. Just use a secondary email for ads. You don't need to purchase.

I believe you can even uninstall the app after changing these settings, but I'm not sure.

Edit: Now I am actually unsure if these are for the system notifications. I hope someone can confirm this works. I know my voicemail notification is gone using the setting (except at first boot, which is way better than it showing up every minute)

I noticed that I may have doped, because the SD card settings might be for the app itself, which would make more sense. However, again, the voicemail setting affected the system notification, so there might be a possibility the others work too.

I hope my rep doesn't go down after I just registered for this community. -.-

share|improve this answer
    
Seems interesting. I can't test it as I no longer have the phone referenced in my question, and the app you mentioned isn't available in my country (presumably since voicemail is almost unheard of here). –  Scott Severance Feb 21 '13 at 5:12
    
Ah, well I updated my answer. There is a chance that the app may not be the correct fix after all. I'd need someone to test it, as ICS isn't officially released for my phone, and the unofficial betas are quite unstable still. (Atrix 4G) –  Drakonas Feb 21 '13 at 20:10

I had the same problem and had tried all the stupid cache cleaner apps which in my opinion only take up even more disc space. I have a 32 gb card and so everything was on that and had manually cleaned everything out myself. The only thing that got rid of the warning was this.go to Mesg folders and find the junk folder. I had over 1000 msgs in there. The only problem was i had to delete them all one by one. I couldn't find a way to delete the entire folders content with one click so it took me a while. I haven't had the warning since so this seems to have cured the problem for now.oh and remember to keep on top of that folder in future. I wil lol.

share|improve this answer

SD Maid might help. You could download it, use it and then uninstall it since it takes up 3 MBs itself. Then just re-download it later if needed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.