Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

My calendar is full of facebook friend birthdays! and worse, they are listed under "My Calendar", not Facebook calendar, so I can't hide them by unchecking Facebook in Calendar, Settings > Calendars. Even thouh they are listed under My Calendar, they still have facebook logos on the entry and a sync logo. I tried by turning off the sync option, but they are still there. How can I remove them from my calendars, and add them to the "facebook" calendar?

share|improve this question
    
I have the same issue with a Facebook event I accepted by mistake, can't get rid of it off my calendar either. Even although I've removed it in Facebook. –  Alastair Oct 25 '10 at 9:31
    
birthday is worse because it makes your calendar really full, lol. –  Louis Rhys Oct 25 '10 at 12:03
    
How did they get there to begin with? Via the official Facebook app or something else? –  Bryan Denny Oct 25 '10 at 15:38
    
I think it must have gotten there from built-in account sync. I can remove my facebook account and check whether they still remain, but I'm a bit reluctant to do this because 1) it will mess with my contacts and 2) I'm not sure whether the birthday will really be removed when I do that. –  Louis Rhys Oct 25 '10 at 16:45
    
i have all my FB birthdays on my Google calendar TWICE. I have a Sprint Samsung Epic. Any thoughts? I don't want any FB birthdays on my Google Calendar at all. –  Suzy Feb 11 '11 at 4:26
add comment

4 Answers

This was reported in the Android Central forum here with a link to LifeHacker. It sounds like it will allow you to sync your Facbook calendar without the birthdays because you're exporting the events directly from Facebook. First, you may want to undo the sync that you have going on now. Hope it helps.

Quoting the post from Android Central:

just go to your google calendar thats linked with your google account on your phone and then follow this article.

Add Your Facebook Events to Google Calendar

  1. In Facebook, go to your EVENTS page.
  2. At the top of that page click EXPORT EVENTS
  3. You'll get a pop up window with a URL, copy it.
  4. In Google Cal, on the bottom left you'll see ‘Other Calendars' and below that a link to ADD. Click ADD
  5. One of the new options you'll be presented with is ADD BY URL, select that
  6. Paste the URL from Facebook where it asks for it.

and thats it! when your phone calendar syncs with your google calendar, all your facebook events will show up too and no birthdays.

share|improve this answer
    
the problem is that the birthdays show up as entries from "My Calendar", not as a Facebook event (they still have facebook logos on the entry and a sync logo though). I unchecked Facebook from calendar sync setting but still the birthday show up in the calendar. –  Louis Rhys Oct 31 '10 at 15:04
    
It may be because the birthday's are syncing through the Contact Sync, then syncing from your contacts to your calendar. –  Matt Nov 28 '10 at 3:46
    
@matt: how to cancel that? –  Louis Rhys Nov 29 '10 at 5:21
3  
I awarded the bounty because it's about to expire and I dont want to just lose 50 rep to the air :D but still the issue is not solved :( –  Louis Rhys Dec 2 '10 at 16:56
    
@Louis I wanted to earn that bounty so I added Facebook to accounts that sync, then added FB to the calendar. Birthdays only show up when I have a the FB calendar added. Like @Matt suggests, it could be something other than FB that's causing this. Trying playing around with which accounts are synced. Go to Settings > Accounts & Sync (or something like that). –  gary Dec 2 '10 at 17:21
add comment

Go into Accounts and sync in Settings and remove Facebook HTC Sense and your calendar will be back to normal. Stupid thing had my calendar full of birthdays from my Facebook that I don't really care about....

share|improve this answer
add comment

There is a downward-pointing arrow on the top right of of the calendar. Hit this, and a list of all your calendars drops down. Untick the ones whose events you don't want synched to your phone's calendar.

share|improve this answer
add comment

I simply stopped syncing the Sense Facebook app to fix this. However, all the contacts I connected with Facebook are gone as well which is the down side.

share|improve this answer
add comment

protected by Community Dec 19 '11 at 20:07

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.