Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I live in Kiev, Ukraine. My device is Motorola Defy with CyanogenMod 7 (2.3.7). In time settings there's no Ukraine timezone so I use Minsk, Belarus timezone (GMT +3). After I locate my position using GPS my phone's timezone changes to African (GMT +2).

Is there any way to disable GPS time synchronization on android?

My phone is rooted.

share|improve this question
1  
I cannot verify (as I'm not having this problem), but you might try setting the time to "manual" (uncheck the "auto" option in settings->time & date), and use e.g. ClockSync for time syncing. for that app there's even a specific TimeZoneDB for ClockSync for -- as the dev puts it -- "Soviet Russia". And please let us know whether this helps. –  Izzy Aug 14 '12 at 15:05
add comment

1 Answer

Android does not synchronize neither time nor time zone with GPS (I don't know about CyanogenMod but I don't think it works in some other way).

Android does synchronize both time and time zone with cellular network. I guess that your cellular network sends to you wrong time zone (African). You can disable it by unchecking "Automatic time zone" in Settings -> Date & time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.