Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

That question occured to me when I saw the WIFI_MODE_FULL API documentation:

Wi-Fi will be kept active, and will behave normally, i.e., it will attempt to automatically establish a connection to a remembered access point that is within range, and will do periodic scans if there are remembered access points but none are in range.

However, in my recent experience, my Nexus One never connects automatically to my remembered networks (It just displays the notification that some open networks are available). However the programming API suggests that it should be able to connect automatically - how can I configure my phone to do that?

I have a Nexus One with Android 2.2.

Edit: Thank you for your comments. After checking, I have found that my N1 does connect automatically to the remembered networks - but after I have left it to sleep, it is never connected (even though I set the Wifi sleep policy to "Never") - and when I open the Wireless configuration panel, I find that my remembered networks are "disabled". How can I prevent that?

share|improve this question
3  
That is odd. It should just connect. That is why my Droid does, and I'd find it hard to believe that the Nexus One is different. I believe that is a feature of Android, not the phone. Are you using any other apps the control the WiFi like Quick Settings or Tasker? –  Matt Oct 25 '10 at 16:27
3  
Same here. It should automatically connect to any networks you have previously connected to before. –  Bryan Denny Oct 25 '10 at 17:54
    
@Matt, @Bryan Denny: Thank you for your comments - I have found that the incriminating behavior happens after the screen is turned off, then on - despite setting the wifi sleep policy to "Never", I find that my phone is never connected in these cases. –  jhominal Oct 26 '10 at 4:05
    
I've just started seeing this same problem after the latest Froyo OTA upgrade. Maybe that's related? –  Jacob Nov 3 '10 at 19:57
    
@Jacob: Set your wireless connection Sleep Policy (advanced settings in Wireless Configuration) to "When screen turns off". If the problem persists, then it is different from mine. –  jhominal Nov 3 '10 at 22:09
add comment

4 Answers

up vote 2 down vote accepted

I have this same problem, intermittently, with my N1/froyo/CM6. I don't know why it happens, but it's been happening since the froyo update afair.

I've noticed it happens less often if I stay in one place. This led me to the theory that, since I live at a university, the fact that networks will pop in and out of range even as I enter my dorm and walk up to my room will make my N1 think that the network's unstable and thus disable it.

Toggling definitely fixes the issue.

share|improve this answer
    
That could be it. Would mean that in fact, choosing the "Sleep = Never" option can negatively affect usability. (Because it disconnects and disables the device while screen is off.) –  jhominal Oct 28 '10 at 5:00
add comment

You could kill two birds with one stone... y5 is a little app that automatically toggles the wifi connection when you enter/leave cells with known wifi access points. I would bet that toggling wifi might help it connect when it detects a network it knows.

share|improve this answer
add comment

I have had a similar problem, though intermittent, on my ADP2 (=MyTouch 3G) running Froyo (via CM6). I believe that networks become disabled when a connection attempt fails. I suspect something like the first connection attempt occurring when you are only barely in range, and once that fails, the network is "disabled" until you explicitly choose it and successfully connect.

share|improve this answer
    
Thank you for your reply - essentially the same as Sohum's - but there can be only one accepted answer. ;) –  jhominal Oct 28 '10 at 5:01
add comment

I have the same issue with my Dell XCD35 (Froyo 2.2) I'm guessing the issue is with the OS and not the instrument. Using all the possible techniques don't work. The only way the connection lasts is if the phone does not sleep - and since that's not an option. Only solution is to downgrade (I have no issues on my Eclair 2.1 Galaxy 3) or upgrade to Gingerbread.

If anyone has solved the matter without either of the above issues, please let me know too. I am stuck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.