Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

As you might know, when you try to change the wallpaper on ICS (for your homescreen), the OS will ask if you want to set the same wallpaper to the lock screen, and the proper "do not ask again checkbox". By mistake, I pressed it, but I want it back now

Any way to achieve that?

BTW, I checked the "Clear Defaults" in the Gallery app - nothing. Using Android ICS 4.0.3

share|improve this question
    
I don't get that option in my vanilla ICS. Which phone do you have? –  roxan Jun 14 '12 at 3:39
    
I have a Samsung Galaxy S2 I9100. But I found out the problem — read below! –  AeroCross Jul 11 '12 at 16:01
add comment

2 Answers

Gallery>clear cache and clear data> uncheck and recheck notifications.

share|improve this answer
add comment
up vote 0 down vote accepted

The problem was a silly one. When you try to select a wallpaper you're given two choices: full wallpaper for the virtual desktop (option 1, scrollable wallpapers) and a fixed wallpaper (the second option).

If you select the second option, it will ask if you want to use the same wallpaper for the lock screen.

However, if you select the first one, it won't ask you anything (because it can't be set) — ths was the root of the problem.

I'm assuming that, if you do tap the "Do not show this dialog again" can be reset by tapping "Clear defaults" in the Gallery App.

share|improve this answer
    
Thank you for the answer :). –  roxan Jul 11 '12 at 17:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.