Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am currently running the Favum 1.1 ROM on my toshiba thrive, and I tried to use Font Installer to install a new system font. For some reason the font will install, but the actual font on my thrive won't change even when I restart and wipe the davlik cache. Is there any way to change the system font?

I can't find the system/font folder anywhere either.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted
+150

In GB 2.3, the fonts folder is located in /system/fonts, how it works is this, for a font face, it copies the fonts to the original droid fonts names at the same time retaining the pre-defined font names in place.

In my rom, I have this, from adb shell,

sh-4.1# cd /system/fonts
sh-4.1# ls -l
-rw-r--r-- root     root         4824 2012-06-13 16:49 Clockopia.ttf
-rw-r--r-- root     root        86784 2012-06-13 16:49 DroidSans-Bold.ttf
-rw-r--r-- root     root        74656 2012-06-13 16:49 DroidSans.ttf
-rw-r--r-- root     root      3725920 2012-06-13 16:49 DroidSansFallback.ttf
-rw-r--r-- root     root       119380 2012-06-13 16:49 DroidSansMono.ttf
-rw-r--r-- root     root       185228 2012-06-13 16:49 DroidSerif-Bold.ttf
-rw-r--r-- root     root       190304 2012-06-13 16:49 DroidSerif-BoldItalic.ttf
-rw-r--r-- root     root       177560 2012-06-13 16:49 DroidSerif-Italic.ttf
-rw-r--r-- root     root       172916 2012-06-13 16:49 DroidSerif-Regular.ttf

Notice how the names are retained but are in fact Roboto fonts! :)

Sounds like the fonts are installed into a different name in which the ROM is not picking it up. For example, suppose the font's name is 'MyFont.ttf' and that gets copied over, but is not copied into 'DroidSans.ttf'... just a guess.

BTW, what Android is that ROM you're referring to?

Edit: It has been ascertained that this is Honeycomb (Android 3.2.1). Do the following:

  1. Plug in cable to Toshiba Thrive
  2. From command line, issue this, adb shell ls /system/fonts
  3. Select all the text of that output, copy to clipboard, and go to http://www.pastebin.com and create a new paste, paste in the contents and it will create a linky for everyone to see, put that linky into the comments below and will look at it :)
share|improve this answer
    
I did not know this!! I'm referring to the Favum 1.1 ROM. It's only for Thrive models. Any idea how I can fix this? –  nathpilland Jun 22 '12 at 20:56
    
What's the android version for that rom? (You can check in Menu > Settings > About Phone > Android Version) –  t0mm13b Jun 22 '12 at 20:58
    
The version number is 3.2.1 –  nathpilland Jun 22 '12 at 21:53
    
Honeycomb it is, and it uses the same filenames as in Gingerbread for the font names... the location of it is still the same i.e. /system/fonts - can you pastebin the contents of that directory to confirm this? –  t0mm13b Jun 22 '12 at 21:59
1  
you need to remount the partition as read/write-able and copy over the font, you are responsible if your display looks messed as a result of the font, which may not shrink down properly to the resolution of the display thus distorting the ui, that is a risk.. do a backup first before modding :) –  t0mm13b Jun 22 '12 at 22:55
show 20 more comments

I use Rom Toolbox for this. Swipe left twice to get to the Interface section and chose Font Installer. If you're rooted, you'll see the new font after a reboot/hot restart.

share|improve this answer
    
That still didn't change the font... I granted it superuser permissions, installed a font, the restarted. Still no change. –  nathpilland Jun 18 '12 at 20:38
    
hmmm.. a conundrum. Perhaps Favum ROM uses fonts from a different than default location? Will look.. –  jlehenbauer Jun 19 '12 at 1:30
    
Or maybe I could add a font folder..? –  nathpilland Jun 19 '12 at 4:12
    
you probably have to locate the existing one. –  jlehenbauer Jun 19 '12 at 12:13
    
Have you tried actually looking for font files .ttf, etc? By issing find / -name *.ttf in a shell? –  Kevin Jun 22 '12 at 14:36
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.