Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When I bought the phone and tried to connect to my wifi network it worked fine, but after 2 days, I don't know why, it just doesn't detect my wifi network.

When I go into Settings->Wireless & network Settings-> Wi-fi settings my network doesn't show up there. Lots of other networks appear there but not mine.

I tried configuring manually with SSID WPA/WPA2 PSK and it says not in range. After this I tried rooting phone but still no luck.

I have a Galaxy SII and 2 other computers working correctly with my network. What's causing the WT19i to be unable to find it?

share|improve this question

1 Answer 1

Check this forum out, since you're rooted now:

SGS2 I9100G keeps disconnecting from WIFI after installing firmware XXLPQ

Try installing a new kernel (usually found on XDA).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.