Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

i tried this tutorial and in step 1 i followed method 2. I try step 3, and when i try

adb shell it works fine. but the line after,

sh /sdcard/motoroot-step1.sh, I get

sh: Can't open /sdcard/motoroot-step1.sh

Why is this happening?

share|improve this question
    
I guess it worked after you switched off usb mass storage? please do let us know how you got on :) –  t0mm13b Jun 25 '12 at 13:39
add comment

1 Answer

up vote 3 down vote accepted

You cannot execute either binary or shell script that resides on the external sdcard due to the execute permission bit being blocked.

Either move the script temporarily to a location other than sdcard (if you're not rooted - you're in a bit of a spot there...)

After reading the posting on xda, it would appear that something is amiss, notify the developer of that forum and post it there and see what response you get :)

Edit: You have that external sdcard treated as mass-storage device. Turn that off and see what happens (Had to read all of the thread and some one posted - see #18 there!)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.