Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I believe this started after I installed the Google+ app, but there is a constant notification that looks like a warning sign, and it displays this:

Google sign-in

Entering the correct password does not dispell it (it's the same password every other Google app uses, and only one is complaining). Also, every Google app still works, each one acts as if I'm still signed in. So where is this coming from, and how can I get rid of it?

Update: I have tried both clearing the data for the Google+ app (which helped for about a half hour) and actually resetting my password and using the new one. Neither worked.

share|improve this question
1  
Do you have multiple users on your device? I once ran into something similar in which an app was looking for the second user name on my device, rather than the usual one. –  gary Jun 28 '12 at 19:18
    
I have two accounts, how did you fix the problem then? I tried typing the password for the other account and nothing happened... –  jlehenbauer Jun 28 '12 at 20:50
    
I saw this issue on the lock-screen. After attempting the pattern too many times I had to enter email/password. However it was my wife's info that unlocked the phone. It was probably due to having her signed in last (either on Gmail or the Market). Also, I assume the username field is filled in for you? It was not in my case. –  gary Jun 29 '12 at 0:31
1  
Same thing happened to me yesterday.. –  Sachin Shekhar Jun 29 '12 at 3:17
    
(1) What version of Android are you running? (2) If you're on an ICS build do you have Chrome installed? –  JonnyP Jul 5 '12 at 20:48
show 3 more comments

10 Answers

up vote 4 down vote accepted

I had the same problem. My solution was to uninstall and reinstall Google+ and everything worked fine after that.

share|improve this answer
    
After trying all of these other methods, I think this is what finally did it. The sign-in error hasn't come back yet, so presently, the correct answer is yours! –  jlehenbauer Jul 6 '12 at 12:09
add comment

This just happened to me as well. I had to change my account password via the website, and then my device accepted the new password.

It only happened with the account I use for Google+, so I think your guess is correct.

share|improve this answer
    
I cleared the data for my G+ app and that seems to have worked for now too, I'll let you know if it holds though. –  jlehenbauer Jun 28 '12 at 19:24
    
it came back :/ so I reset my password online, and used that one, and it still refuses to go away :( –  jlehenbauer Jun 28 '12 at 20:12
1  
@jlehenbauer Hmm. My exact process was: (1) See notification (2) Click it and type in password a bunch of times (3) Open Gmail, get password popup (4) Try password again (5) Leaving popup open, reset password on website via PC (6) enter new password in popup. At that point I still had the system notification in my tray, but (7) I cleared it and rebooted. No issues since, I just opened G+ and Gmail with no error and turning sync on and off for the account didn't trigger a notification either. –  Matthew Read Jun 28 '12 at 21:54
    
I think this worked for me: (1) See notification (2) Click it and type in password a bunch of times (3) Change password on Google via PC (4) Try it again in Google+, to no avail (5) Go to Play Store, popup comes up again (6) enter password and it works! –  jlehenbauer Jun 28 '12 at 22:05
    
@jlehenbauer Weird, I suppose maybe the Market was caching something in your case? Let's hope it stays fixed. –  Matthew Read Jun 28 '12 at 22:25
show 1 more comment

I resolved this by signing out of Google+ and then signing back in. This worked on a stock droid x with Gingerbread.

share|improve this answer
    
trying this now! –  jlehenbauer Jun 29 '12 at 19:07
    
sill no luck :( –  jlehenbauer Jun 29 '12 at 19:21
    
+1 that seems to have fixed it for me –  therefromhere Jun 29 '12 at 23:51
add comment

I had a similar problem trying to sign in play store was not authenticating my credentials even though they are correct. I turned off the 2-step verification using the web and worked later on .

share|improve this answer
add comment

Here is the solution: Login into Gmail, locate Account under the sign-out Name. This takes you to My Account where you click on security. Here you find a section for Application-Specific passwords at the end of the webpage. The issue is explained that: Some applications that work outside a browser aren't yet compatible with 2-step verification and cannot ask for verification codes, for example:

Email programs including Outlook, Apple Mail, or Thunderbird
Older Android smartphones

The root-cause of this problem is that you probably turned on the 2-steps verification without noticing this. So all you have to do is to generate your application specific password and that is it!

share|improve this answer
    
This fixed the problem for me –  wil Nov 6 '13 at 10:28
add comment

Same thing happened since yesterday. It started just after updating the new G+ apps. I thought it was due to my fiddling with 2-step authentication setup, but nope, that wasn't it. Tried reset/reinstall everything. Also tried changing new password. Same thing happened again after installing with the new G+.

I just turned off background sync for G+ (and leave other google apps as-is), and it seems did the trick to stop the error popping up. This is not exactly an answer, but simply a temporary workaround until google comes up with update to fix.

share|improve this answer
    
Have you tried re-enabling background sync for G+ now? I shut it off, waited a while, then turned it back on, and it seems to have done the trick... –  jlehenbauer Jun 29 '12 at 15:53
    
no luck with this either. I'd like it to sync, but turning it off permanently is starting to look like the only solution... –  jlehenbauer Jun 29 '12 at 18:58
add comment

The problem is due to 2 factor authentication.

Go to your Google account on a PC and generate a new Application Specific Password (ASP) (hold off on clicking the button). Enter that into your phone when it asks for a password for Google Sign-in.

If it doesn't work the first time, reboot everything and do it again (remember to hold off on the button until you have entered the 16 character ASP into your phone).

share|improve this answer
    
What do you mean by "hold off"? Do you mean "keep pressing"? –  geffchang Jan 2 '13 at 5:07
    
Wow, after trying everything -- I mean everything including re-installing stuff, this worked. Golly. Could they make it any more difficult. Why wasn't 2 factor with the code generator working Google, eh? Anyways, thanks, fixed now :) –  Saint Hill Mar 1 at 12:20
add comment

Instead, I opened up the security option of my Gmail account in web. I created a new system-specific password and entered the same. It worked, and I didn't even have to reboot.

share|improve this answer
1  
Note: This was probably set up with 2-factor authentication. Hence the ability to set up a specific password. –  Stephen Schrauger Dec 15 '12 at 2:08
add comment

I do not have Google+ installed and I reverified my password via the web and I still could not get logged in to my phone.

I ended up disabling two step verification and I was able to login to my phone after that.

I just remembered when I first enabled two step verification I started getting sign on errors when I used voice search.

share|improve this answer
add comment

I had exactly the same thing happen for the 'Play Store' on an Android phone - it would just not accept the correct password! The method that worked for us was to use a computer, access that Google account and disable 2-step verification altogether.

After logging into Google, navigate to https://www.google.com/settings/ -> Security -> 2-step verification -> Edit -> change that to Off.

share|improve this answer
1  
I you're using 2-step verification your correct password is incorrect! You need application specific passwords. (this is clearly said so during setup) –  Richard Borcsik Jul 5 '12 at 20:46
    
Richard, I had setup the Play Store on a HTC phone without using any app specific password. Subsequently, I reset that phone for my wife, who happened to forget her password. Multiple tries let to a situation where entering the CORRECT password did not work. The only solution that did work was what I described. –  Sid B Jul 5 '12 at 21:57
add comment

protected by Community Apr 9 at 10:36

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.