Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In my new Galaxy GT-I9100 Android version 4.0.3 everything expect WI-Fi is working fine. When I am connecting my wireless it's getting connected, but not able to browse the internet. I tried changing from DHCP to Static IP Address, restarted mobile/Wi-Fi router, removed the battery and checked, it's working for only a few minutes and again the same issue.

share|improve this question

Have you enabled the MAC Filter on your Router?

If you've then you should disable it or enter the MAC Adress of your S2 in the Routerconfig.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.