Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some strange reason, my Android 4.0 ICS tablet is no longer able to access the Internet. First, via wifi, it could'n connect to two distinct networks. Then later, I tried to connect it to home router via dhcp. It could not. As for wifi, the tablet gets an IP number.

I don't know how this happened, if it is a route problem or a dns problem or other. Tried to install a terminal to check a route command, but it is not available (at least to me). So I ask what can I do to solve this issue? Restore original configuration? Other?

share|improve this question

ICS has issues on some devices with Wireless-N. My Acer A500 works properly, but my 2 Xperia phones kill my router instantly if I use the N-draft protocol.

So, try deactivating N-draft mode in your Android device or your router, then it sohuld work.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.