Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am using the (I think default) Calender application on my Samsung Galaxy S phone.

It shows blue blocks for my events in the 7 day view.

Is there a way to change this blue color ? So that, e.g. I can mark private events in green and appointments with customers in red ?

Or is there a way to show some text in the blocks ?

Or it not possible with the default calender .. do you know of another one which does allow this ?

Thanks.

share|improve this question

2 Answers 2

up vote 10 down vote accepted

Yes you can, you will need to create a different "calendar" (probably "tag" would be a better name, but that's Google's terms for it).

Creating a Calendar (do this from the Desktop, I didn't found a way to do it from Android's Calendar app; do anyone know?):

  1. Go to http://www.google.com/calendar.
  2. Look for the "My calendars" box on the left, click on "Add"
  3. Fill in the information, and click Create Calendar.
  4. You can change the color later from "My calendars" box, by clicking on the triangular button.

Creating a Calendar

Adding Events to Calendar (can be done from Android):

  1. On the "Create New Event" view, choose the calendar you've just made from "Calendar" combobox.
share|improve this answer
    
@Lie Ryan: +1 for taking the time to anwswer my question - but, still, it's not exactly what I am looking for, I think. I want to add color to different events in the same calendar. Following your sugguestion, forces me to create google accounts for each type of event I want to enter : personal, customer, holiday, family things - I want to see them all in my own diary, but color codes. –  Edelcom Oct 30 '10 at 8:14
4  
@Edelcom: You can create multiple calendars in a single Google account (that's why I think they are better named "tags" or "groups" or "folders" rather than "calendars"). –  Lie Ryan Oct 30 '10 at 8:41
    
I do exactly what Lie says. I put birthday events in one calendar, etc. –  Bryan Denny Oct 30 '10 at 13:41
    
Ok, I have to change my way of thinking here ... but even than: that's for the Google calender, can you do the same on the local calendar of the device ? –  Edelcom Nov 1 '10 at 5:27
    
@Edelcom: Try this: Press Menu > More > My calendars > Menu again > Add calendar; I can't tell if it works, as in my case the "Add calendar" button is greyed out, it might work in yours or it might not. –  Lie Ryan Nov 1 '10 at 10:29

After following Lie's steps to create a new calendar in Google Calendar, you'll have to add it to the Calendar app:

  1. Open the Calendar app
  2. Menu > My Calendars
  3. Menu > Add calendars
  4. Select the calendar you just added

Lie mentioned this in a comment, but I don't have enough rep to respond.

Add calendar is for adding calendars to the app that aren't in the My calendars list already. It won't let you add new calendars to Google Calendar.

(The above is true on my xt720 running eclair-2.1.)

share|improve this answer
    
Sorry, my version (2.2) does not have a 'Menu > My Calendars' option, just Search, Create , Goto , Today, Delete, More and More having Refresh and Settings . Settings having, Calendars, Calendar sync, Default view ... all view settings and Vibrate . Calendars just a way to enable one of three calendars, My calendar, the online google one and the one from Facebook, pressing menu here only shows 'Calendar sync'. Am I missing an option ? –  Edelcom Dec 2 '10 at 7:28
    
@Edelcom: Are you using the stock calendar application? The stock calendar app have a completely different set of menus. Either you have downloaded an alternative Calendar or Galaxy S ships its own calendar app; can other Samsung Galaxy S owner confirm this? btw, your question tag said you're using 2.1-eclair, but now you're saying you're using 2.2, have you upgraded since then? –  Lie Ryan Dec 2 '10 at 9:20
    
@Lie Ryan: Yes I upgrade my Galaxy S during the weekend. I a running Calender 1.1 - no about settings anywhere to be found. The Application list just shows version 1.1. –  Edelcom Dec 2 '10 at 9:38
    
@Edelcom: Application info shows my Calendar app is version 7 (on eclair). Your "Calendar" must be quite different from my "Calendar". –  idbrii Dec 2 '10 at 20:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.