Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Android Nexus S does not boot anymore. If I start it normally, I get a screen like the following and it won't ever change (tried for hours):


I can still go into the boot loader with PowerOff + Volume Up, if I try the RECOVERY option, I just get a screen that looks like this:

enter image description here

Does anybody know how to install the original google android again, or at least flash it with a similar operating system?

share|improve this question
up vote 0 down vote accepted

If you don't mind to end up with Cyanogenmod9 (Ice-Cream-Sandwich):

Here's the full update guide from CyanogenMod's Wiki:

Here are builds (go for release candidates or stable builds for CM9):

Recovery images are here:
flash via 'fastboot flash recovery [recovery.img]

share|improve this answer

To install the stock ICS build: go to and choose your device (mine, for example, a US Nexus S that works with T-Mobile, is, download the file, then download the surprisingly-not-very-large Android SDK from Run the sdk manager (it's called "tools/android") which will open a GUI; make sure "Android SDK" and "Android SDK Platform Tools" are checked. You can clear other check boxes, since those will download very large stuff that you don't need.

Once you've got all that, follow the instructions in the tarball that you first downloaded; roughly, you want to put the sdk's "platform tools" directory on your PATH, power off your phone, then hold the power-up key and power it back on (that'll get it to display the Sekrit Startup Screen); and then on your computer run "fastboot oem unlock" and then "".

I've done this twice in the last few days (for fun :-) and while it may sound complicated, it's actually pretty easy and worked fine. (I installed 2.3.6 just for the nostalgia of it and then installed Cyanogenmod and then went back to stock 4.0.4).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.