Sign up ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Possible Duplicate:
How can I tell the Android Market that I'm running an updated version of Android?

In fact, I installed an higher Android version on my phone (4.0 on a ZTE Blade which normally supports 2.1).

But when I'm connecting to the market with my phone, I'm still limited to that 2.1 version and I can't even see higher version's applications while my phone now supports those...

Is there a way of overriding that version limitation or at least push it to 4.0 ??

Note ::


The limitation I'm facing seems linked to something else than my android firmware. Indeed I can download that app :‌​ch_result (while it requires 4.0 firmware).

But I can't download this one :‌​re=search_result (while it requires 2.2 firmware).

share|improve this question

marked as duplicate by Al E., ce4, Flow, Zuul, eldarerathis Aug 14 '12 at 13:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Silly question: are you sure your rom is a real ICS version and not just Eclair skinned to be ICS lookalike? use 'adb shell getprop \| grep -i version' to verify – ce4 Jul 3 '12 at 13:40
I confirm that it's the good version :: []: [4.0.4] []: [15] – Kuroicloud666 Jul 3 '12 at 13:51
There's seemingly sth. wrong. You wouldn't want to fake your api level. Different question(s): Did you restore system app data using TiBackup? Did you install an outdated Eclair version of the GApps? – ce4 Jul 3 '12 at 14:25
@AlEverett: Were you thinking of this one? How can I tell the Android Market that I'm running an updated version of Android? – eldarerathis Jul 3 '12 at 15:55
OP: ICS rom for the Blade is horribly broken and is suspended...… – t0mm13b Jul 3 '12 at 16:19

1 Answer 1

The problem here is not in the software, but the hardware. You phone uses a CPU that does not support the ARMv7 instruction set that is required by many games these days.
It is more than likely that a recent update for the game dropped support for older instruction sets to improve performance or make the app smaller.

share|improve this answer
So there's no way but to buy a new phone for supporting such apps ? – Kuroicloud666 Jul 5 '12 at 9:01
That's right. The Blade was already obsolete when it came out two years ago. – Richard Borcsik Jul 5 '12 at 10:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.