Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

When trying to import photos from my Galaxy S2 in Windows, it tries to import all image files on the phone (including application data), not just those in DCIM.

The system is Android 4.0.3. The phone is set to connect as a camera (but Windows Explorer can still see the full directory structure on the phone and SD card.)

share|improve this question
    
Do the (unwanted) pictures also show up in your galery on the S2? –  Izzy Jul 3 '12 at 13:54
    
One more thing to please explain: What do you do to import your pictures (e.g. what program you are using)? –  Izzy Jul 3 '12 at 14:48
    
I don't see a question here... If you only want to import certain images, why not use software like Picasa which allows you to selectively import/review images of choice? –  Sparx Jul 3 '12 at 14:53
    
No, they don't show up in the gallery. It's all application data images, album cover files, etc. –  Mihai Jul 3 '12 at 15:05
    
I wonder the album covers do not show up in the galery: if there were a .nomedia in the music folder, it would be really strange... But then, I never had a device with ICS (still running Gingerbread), maybe something's changed... –  Izzy Jul 3 '12 at 15:29

2 Answers 2

up vote 1 down vote accepted

Probable answer by guessing what you are doing: If all those unwanted pictures are also displayed in the galery, and you use some "media-importing-software" (as opposed to just copying files in explorer yourself):

This importing software is probably contacting your Android device's media server for "media of the type image", so it gets all images returned the media service knows about. No big help up to this, but: You can tell the media service to exclude directories from its library by placing an empty file named .nomedia there (the leading dot is essential in the file name!). As soon as the media scanner finds that file, the entire directory it resides in (including all subdirectories) is skipped. If there are any pictures, videos or sound files, they won't show up in the galery (but you still can access them via a file browser if you want), and the media service will not even know they exist. So the next time it is asked for "all media of type image", those files won't be mentioned.

share|improve this answer
    
I'm using the default Windows photo import functionality (I suppose that's where the problem lies); the nice thing about it is that it auto-rotates the photos to the correct orientation. It'd be hard to give that up. I'll see if other media importing software does the same thing. –  Mihai Jul 3 '12 at 15:11
    
Did you try to simply copy the images with the explorer? The auto-rotating is probably done by your image viewer rather by the importer -- that's a standard feature based on Exif tags most photo viewer can cope with. –  Izzy Jul 3 '12 at 15:26
    
That's what I ended up doing, ultimately. Thanks. –  Mihai Jul 3 '12 at 20:40

As of October 2014: See this, it offers a direct way to do just what we're looking for.

Nutshell:

  1. Connect phone to computer
  2. Swipe down from top of phone to get to settings (Samsung Note 3)
  3. tap "Connected as..." and select "Camera (PTP)" to access photo folders.

(Alternatively, tap "Media Device (MTP)" to access all folders)

FINALLY!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.