Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I changed my build.prop for spoofing another device model, I copied build.prop from another device having gingerbrad but my system is froyo. When I rebooted, I lost my internet connection. It reports no ruim card where as it is there. I had installed apks for terminal emulator, busybox etc. but they are not working. Xplore file manager does not work. But free version of Astro File Manager and ROM Toolkit work. I tried to push old build.prop on device using adb but it gives permission denied error as it is read only system. I came to know that adb root and adb remount works if you are in recovery mode. I tried to go into recovery mode, but there is no custom recovery installed on my cheap android phone, so can not go into recovery mode. su does not work in my adb shell. Can anybody tell me the way to mount system partition in rw mode using adb ( without recovery mode ) or is there any tool which will work in this situation ? Thanks in advance.

share|improve this question

migrated from Jul 4 '12 at 1:10

This question came from our site for professional and enthusiast programmers.

I would personally use ES File Explorer to get the original build.prop back into your /system partition. You have to go into the app options and select "mount system read write" and it will be able to write to the /system partition.

The commands for mounting the partition and copying the old build.prop from the root of your sdcard are:

#mount -ro remount,rw /system
#cp /sdcard/your_old_build.prop /system

You don't need to use those though if you are using an app that gets root access.

share|improve this answer
Is your phone rooted? You need to be root as mentioned by anthonycr, in order to mount /system. – Rashidi Zin Jul 6 '12 at 2:29
That will fail if you do not have root! – t0mm13b Jul 6 '12 at 3:19

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.