Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I use a 64 digit hex passphrase on my router that I want to use with Android. However Android (CyanogenMod 7) doesn't seem to accept the password (no errors, just nothing happens when I enter it). I have also tried manually entering the information into the wpa_supplicant.conf file but to no avail.

What could be the problem?

share|improve this question
1  
Why are you doing that? It sounds like a protected wifi network, and by peeling off the hex passphrase from a windows machine, you think you can get on the network. Is it your wifi network? If it is, surely you would have the passphrase. this sounds iffy? –  t0mm13b Jul 4 '12 at 13:01
    
Since the question was edited, what router is it in question? This is a case of a mis-configured router. –  t0mm13b Jul 4 '12 at 15:59
1  
you should see the old revision by clicking on 'X mins|hours|days ago': android.stackexchange.com/posts/25259/revisions PS: I don't think it's a misconfig, more a typing problem with colons included or so. –  ce4 Jul 4 '12 at 16:17

2 Answers 2

That has worked fine when I recently tested it with CyanogenMod 7 and 9 (and also stock HTC/Samsung/Motorola).

Just enter it into the usual passphrase input box but without any colons. Just type in only the 0-9,a-f letters. This should work then.

Here's a sample wpa_supplicant.conf entry with a fake key/AP:

network={
    ssid="insecureAP"
    key_mgmt=NONE
    auth_alg=OPEN SHARED
#   128 bit key:
    wep_key0=0123456789abcdef0123456789
#   64 bit key:
#   wep_key0=0123456789
    priority=90
}

Note: 64bit correspond to 10 hex digits and 128bit correspond to 26 hex digits (with WEP standard)!

share|improve this answer
    
TIL! Never knew you could do it that way... :D Nice... should be part of community wiki for the top gems /tips 'n' tricks for others to submit :) –  t0mm13b Jul 4 '12 at 16:19

Try replacing this:auth_alg=OPEN SHARED for this: auth_alg=OPEN

It just happened to me that my phone was trying Shared Key Authentication (SKA), which is seldom used in favour of Open Authentication. By doing this my connection started working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.