Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem with installing apps from Google Play onto my Samsung Galaxy S Plus phone.

It has Android 2.3.6. Yesterday I tried to download some apps. When I clicked 'Install', the app began to download but when it got to 100% it just disappeared and silently failed to install on my phone :\

I don't have an SD card and up to now I saved all my apps on the phone and had no problems like this. It seems to be some settings problem, but I don't know what to do. any ideas?!

share|improve this question
Do you have access to the device log (logcat)? That's sadly a chicken & egg problem (you'd need some additional app to see logs, e.g. and attach the output from a failed install attempt to this question). That can also be done by installing the SDK and use the integrated log viewer from there, but that's not too straightforward. – ce4 Jul 5 '12 at 12:31
Is there sufficient space available on your phone to install the apps? – Bryan Denny Jul 5 '12 at 13:34
It sounds to me like the infamous /cache or /data/data out of space problem. I hope google addresses this issue and gives more space for these mounts. Usually there is plenty of room to install in /data/app, but the cache and data locations run out of room quickly. – Ryan Conrad Jul 5 '12 at 21:03

Its indeed quite possible that either the two directories residing on the filesystem, /data/local/download or /cache/download is probably full of temporary files and is not deleted which contributes to the symptoms of the app not installing after 100% downloaded.

Some ROMs do have this facility or feature in place, called run-parts, which is invoked by the busybox which does this clean up on boot to clear out the temporary downloaded files saved in the specified directories. Again, this is dependant on the ROM.

Maybe that's what you should try doing, reboot to force the system to clean up the directories and try again upon bootup?

If that fails, then it sounds likely that the /cache partition is very small not to hold the downloaded files. The trick employed by ROMs is this, the /cache/download is either sym-linked to /data on the /data partition. The other trick is that /data/local/download is re-binded to the /cache/download directory. (see this script below to see what the second trick is about)

# bind mount /data/local/download to /cache/download if cache
# partition is too small

CACHESIZE=$(df /cache | tail -n1 | tr -s ' ' | cut -d ' ' -f2 | tr -d [:alpha:])
DATAONLY=$(getprop dalvik.vm.dexopt-data-only)
if [ $DATAONLY -eq 1 ]

  /system/xbin/busybox mount -o bind /data/local/download /cache/download

rm /cache/download/downloadfile*.apk >/dev/null 2>&1

exit 0

Why /cache and /data/local/download? it is found in the init.rc script in the ramdisk of the ROM in question which has the following environment variables that tells the Google Play store, where to save the downloaded apps.

export ANDROID_CACHE /cache
export DOWNLOAD_CACHE /cache/download

The only thing I would suggest is to use File Explorer (just as I type this I realised yeah, root... but I digress), and clean out the directory manually for a start.

share|improve this answer

I was having a similar problem. When trying to install an app from the market, it would get to 100% download, then say download failed. Also, the same behavior occurred with updates to previously installed apps. Tried all sorts of things from various forms and nothing worked.

I am running Eclair, and decided that my phone was becoming a paperweight without these updates... So I resolved to install a new ROM, thankfully I did not have to go that far. I ran a one-click root application, and afterwards I could download updates and install new apps without issue.

Pretty sure rooting your phone will void the warranty, if that is not of concern and your at a dead end... perhaps give it try, it worked for me.

share|improve this answer
I'm sure there must be other solutions as well, apart from installing different ROM. I get similar problem sometimes on my HTC Desire but it works after some retry. – roxan Sep 19 '12 at 8:26

Someone already solved this without rooting the phone by uninstalling updates for Google Play Store app: Go to Settings → Applications → All (tab), scroll down and tap "Google Play Store", then "Uninstall updates".

Source: SamsungGalaxyForums

share|improve this answer

Before uninstalling updates I would also try Clear Data (same place - under Google Play in Application Manager). That fixed the same issue for me.

share|improve this answer

I fixed the problem by going to App manager and uninstalling updates to Google Play. Things will download and install fine after.

share|improve this answer

This actually worked for me and my phone is ZTE N9130 . I went to Google play and stopped the Sync updates. Then proceeded to downloading Apps on Google Play. Also I made sure that I had on the Data and GPS button on. Everything continued to download in a matter of time. Yay!

share|improve this answer

Solution: Galaxy S(First Series) will easily handle 4.0 Kit to JB Get the latest working galaxy toolkit, unlock the boot-loader:

Yes, You can uninstall updates for Google Play but that gimps your device. How to: Links are hit or miss dead. Look up "Galaxy Tool Kit"

Those kits include step by steps.

share|improve this answer

I just found a new incompatibility causing something similar (at least right now: May 2015). Updates and reinstall of Facebook were repeatedly failing with "Package invalid" using both Google Play and 1Market.

It seems that the problem was my home program: Nova launcher.

This was on Bluestacks using my PC, by the way.

I changed my home program back to Gamepop-Home (the default that came with Bluestacks) and was able to install Facebook from the search box in Gamepop-Home.

Afterwards, I was able to go back to Nova Launcher and keep using Facebook.

share|improve this answer

You either ran out of space, or you had updated Google Play.

share|improve this answer

protected by Community Dec 20 '15 at 6:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.