Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I had some wifi connection dropping issues with my One X. I don't appear to have the "you're holding it wrong" issue (the squeeze test comes out negative), but some googling found that there seem to be issues with 5 GhZ WiFi bands as well.

It eventually turned out to be some sort of known incompatibility between the One X and my router's firmware (a router update fixed it), but in the process of testing, I tried to disable 5 GhZ WiFi. However I had to disable the 5 GhZ band on my WiFi router (and thus disable it for all my devices) because I couldn't find a way to disable it on the phone.

A posting in the thread above contains

In the WiFi settings, under the menu, "WiFi Network Bands", select "2.4 GHz only".

However I cannot find such a setting. Am I just blind? Or is there at least another way to disable 5 GhZ on a (non-branded, non-rooted) One X?

share|improve this question
    
Where exactly are you looking? I have what appears to be the same option on my Galaxy Nexus if I go into the Wi-Fi settings, press the overflow menu (the "three dots" button) and select "Advanced". It's listed as "Wi-Fi frequency band". Maybe getting a screenshot of what you see in your settings would be useful if you can do it (does Volume Down + Power work on the One X?). –  eldarerathis Jul 5 '12 at 13:46
    
@eldarerathis Yes, screenshot works on One X (didn't that finally make it into a standard Android feature?). Anyway, I did check there; this is all I see behind the advanced wifi settings: i.stack.imgur.com/NCQbE.png –  balpha Jul 5 '12 at 13:57
    
Yes, it's standard in ICS, but I don't know if some manufacturers decided to move/alter it. Maybe the setting that others are seeing is due to carrier/regional differences in firmware or something. That would be fairly annoying if it's the case. –  eldarerathis Jul 5 '12 at 14:09
    
After some reading it appears that HTC has released an update to fix some Wi-Fi issues, but I'm not sure if it will necessarily fix your problem. –  Matthew Read Jul 5 '12 at 17:13
1  
@Wartickler non-branded = I didn't get it from a carrier, I just bought it at the store (I don't know about the US, but here in Germany you don't have to get your phone from your carrier). non-rooted = I didn't root it. –  balpha Aug 27 '12 at 12:55
show 2 more comments

2 Answers 2

Based on this review of the Wi-fi capabilities of the HTC One X from anandtech it would appear that the option is there. Look two-thirds of the way down on the site and see this image:

image from anandtech

share|improve this answer
    
The international One X doesn't have that setting (I'm looking at mine right now). It may be that the US/LTE version doesn't have it either. –  Cry Havok Aug 26 '12 at 9:03
    
Can you resize that image? :) –  t0mm13b Jan 14 '13 at 19:36
    
Hmmm...it comes from the website. I'll see what I can do (: –  Wartickler Jan 15 '13 at 13:25
add comment
up vote 0 down vote accepted

I assume this was just a bug; this option re-appeared in the "Advanced" Wi-Fi settings after one of the OTA updates.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.