Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

On my Galaxy S3 / ICS handset, and also I expect on my previous Galaxy S / Froyo I'm unable to save any links from my web server due to the fact that it requires a user authentication. I can browse the site happily in Chrome and the default browser, but when I go to save a link, whatever it is that does the downloading sends in an HTTP request with no user agent not authentication header set, so the download fails, with a 401 error being returned.

What gives, peeps?

share|improve this question
    
Does it work with a different browser? –  Matthew Read Jul 12 '12 at 19:21
    
No, I just tried with Dolphin HD too. I don't think its the browser doing the download, it seems to hand off to some sort of generic subsystem. Works fine on my desktop though. –  Chris Phillips Jul 12 '12 at 21:14
    
Hmm, strange... –  Matthew Read Jul 12 '12 at 21:15
    

1 Answer 1

You can use Firefox to get around this at the moment. The bug has been going on since 2008.

share|improve this answer
    
I've been using Opera actually, so yeah as long as it's a different engine to Android default one it works. –  Chris Phillips Mar 9 '13 at 17:28
1  
The issue is not the browser, it's the download manager. The authentication details are not passed to the download manager by the browser. This isn't a problem in Opera or Firefox as they use their own download managers. –  Chris Evans Mar 10 '13 at 1:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.