Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have recently (since ~1month ago) experienced the following problem:

  • When I get new mail on my gmail account, Gmail will usually not autimatically retrieve it (e.g., no notification; and when I manually open GMail app, the mail will NOT be in the inbox)

  • However, manual mail retrieval/sync DOES work fine, for example if I click on "Sync" (retreieve) curcle icon within GMail app; or on Elixir 2's "start background data sync" icon; or check-off-and-back-on on the "Mail Sync" in Settings->Accounts for relevant Google account.

  • Also, sometimes Gmail does get retrieved/notified; I am not 100% sure but there seems to be a very strong correllation between that and having recently opened GMail app (especially in foreground).

  • GMail sync worked perfectly find till ~1 month ago

  • The background sync does not work for ANY of the 3 Gmail accounts I registered.

  • OTHER mail apps seem to sync perfectly fine (e.g. Hotmail or Yahoo mail) in the background.. So I have a hard time believing it is a problem with overall sync.

  • The issue is independent of network - it doesn't work on WiFi or 3G.

System details:

  • Droid X, running rooted stock Froyo 2.2.

  • I have gone through 100% of intents in Autostarts and made sure every single intent is ON for both Gmail listener and Google Framework.

  • Gmail version is 2.3.6 (it has a 7/1/2012 backup in Titanium Backup Pro, so I'm assuming this is when it was last updated. BUT the problem existed before 7/1)

  • Background sync is turned ON - confirmed via Quick Settings app as well as widgets from Elixir 2. (also, as noted above, Hotmail and Yahoo mail seem to sync fine)

share|improve this question
    
Have you considered the network condition? Did you "Enable always-on mobile data" in Settings -> Wireless & networks -> Mobile networks? –  spica Jul 13 '12 at 17:06
    
Yes, and yes. If you carefully read the question: (1) OTHER mail apps sync in background; (2) Gmail almost NEVER syncs automatically (unless the app is running in foreground and was just synced manually before). –  DVK Jul 13 '12 at 17:08
    
Try looking into logcat for any errors relating to GMail. –  Chahk Jul 13 '12 at 19:12
1  
Is Gmail sync on? And lose that task manager. –  Richard Borcsik Jul 13 '12 at 19:18
    
@RichardBorcsik - How can I tell if Gmail sync is on or off? Settings->Accounts has "Mail" turned on. And ATK is kind of irrelevant here - Gmail is whitelisted, so are pretty much all server processes except the ones I 100% know are safe to kill. And it was this way for >1 year. –  DVK Jul 13 '12 at 19:37
add comment

2 Answers

I had a similar problem, Gmail sync would rarely work, for 3G and for Wifi.

My Galaxy S3 runs 4.0.4 stock ICS, background sync is enabled, and so is a mobile data limit. Wifi is set to sleep on display off.

What I didn't realize, is in the Settings -> Data usage -> Gmail, I accidentally checked the box "restrict background data". This correlates to "Also, sometimes Gmail does get retrieved/notified; I am not 100% sure but there seems to be a very strong correllation between that and having recently opened GMail app (especially in foreground)."

Wifi background sync should work, but if you have Wifi to sleep when screen off, then you still would fail to get notifications!

share|improve this answer
    
This doesn't apply since my problem was on 3G, not wifi. Interestingly, my GMail problem went away on its own, but instead now my Hotmail notifications have exactly the same problem. –  DVK Nov 23 '12 at 20:28
    
This does apply, as I had the problem with both Wifi AND 3G. Glad to hear your problem went away, but there is no such thing as random events, everything has a cause. Do you have an application "Light Manager", it can mess with notifications... –  kevinf Nov 29 '12 at 21:59
    
OK, I figured out Hotmail problem. For some strange reason, some of the Hotmail intents were turned off. I turned them back on in Autostarts. I STILL have no clue about Gmail –  DVK Nov 29 '12 at 22:04
add comment

I had the same problem. After reading kevinf's answer, I found the solution by checking the general Google sync settings. Gmail was not checked!

Settings->Accounts/Google->YourEmail@gmail.com Last synced MM/DD/YYYY 12:00 PM->List of Google Sync Settings.

As a side note, the Gmail app indicated that sync was turned off.

Gmail App->Menu/Settings->YourEmail@gmail.com->DATA USAGE/Gmail sync is OFF
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.