Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Have done my bit of research but couldn't find a good solution. When I sync the contacts with my primary Gmail account, the Contacts get filled with all of my Google Contacts including those from Google+ (1000s of them) which I obviously do not want to be in my phone.

How do I prevent this from happening ?

  1. I do not want to create a new Google account just as a workaround
  2. Have tried to locate the possibility of syncing just with a specific group. But can't find it in S3
  3. I do not prefer 3rd party contact managers
share|improve this question

5 Answers 5

Settings > Accounts > Google > Google+ > UNCHECK "Keep Contacts up to date"

share|improve this answer

I didn't want all of my Google Contacts to display because that is not where I store phone #'s. I was able to get the GS3 to only show contacts that have a phone # by going to: Contacts > click on Settings button, scroll to bottom and click on Settings again and then choose "Only contacts with phones". This way, I have my Google Contacts on there, but not the ones that I use only for emailing.

share|improve this answer

If Sparx's answer is not an option, the I suggest to simply hide the Google+ contacts in the app. This does not prevent syncing but it's a sufficient solution. For ICS open the contacts app, select the list view and press the context menu button, which should present a menu with the "Contacts to display" option.

share|improve this answer

An option I went with was that in my g-mail account, I deleted all my contacts. I then synced my s3 with my google account so that it updated with the 0 contact list. Once I cleared my contact list from my phone, I unchecked the syncing option so that I wouldn't have this problem again. Back on my gmail account, I undid deleting the contacts so that I could retain my contact list in my email (revert it back to before this process), but still have 0 of those contacts on my S3.

Hope that helps (even though it's 2 months late).

share|improve this answer
    
It sounds like this does only delete the Google contacts and not the Google+ contacts. Plus your device won't be able to sync the Google contacts in the future. Sorry, but I would not recommend this option. –  Flow Oct 4 '12 at 8:48

Open the Google+ app. Click the MENU button and choose SETTINGS.

Uncheck ADD CONTACTS FROM GOOGLE+

share|improve this answer
    
This option was not on my Google+ App (Build 3.0.1.31545355) on my Droid 3 running Android 2.3.4 –  Dylan Yaga Jul 19 '12 at 15:48
    
@DylanYaga It's only on ICS and newer. Before that you just hide the group that you don't want to see. –  Richard Borcsik Jul 19 '12 at 18:14
    
Is it possible that unchecking this will not remove the already synced contacts with? How can I remove those as well? –  Steven Roose Dec 19 '13 at 19:53
    
Ok it just took several minutes to make the change. –  Steven Roose Dec 19 '13 at 20:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.