Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

So, Jelly Bean is supposed to have offline voice recognition, right? I've encountered several situations where the voice-keyboard has said that Google is not available. Has anyone else seen this behavior? If so, how do we fix it?

I've noticed the problem in areas where I have questionable mobile data or wifi access. If I have a good wifi / mobile data signal OR if I enable airplane mode (disabling data completely), then it all seems to work ok.

I'm using a GSM Samsung Galaxy Nexus, FYI.

share|improve this question
    
comment from new user: "Data point regarding Now > Settings > Voice > Download: My Nexus 7 delivered with JB already has English installed. Nonetheless I have seen "Can't reach Google" while using speech recognition, when I was on a known strong wi-fi broadband connection. My device is 4G and 2 weeks old, so I haven't had much occasion to test speech without an internet connection." –  Peanut Jan 9 '13 at 17:12
add comment

2 Answers

Have you downloaded the files for you language, that supports offline voice recognition? Under Google Now, hit the menu button at the bottom, select Settings, select Voice, then the option to Download offline speech recognition.

Also, it could depend on what rom of JellyBean you are running. Some things work better than others in certain roms...

share|improve this answer
    
I'm using the official 4.1.1 Google ROM for the Galaxy Nexus. The dictation works when completely offline, so the language pack must be installed locally. –  Trevor Sullivan Jul 23 '12 at 1:57
    
Ah, fortunate enough to have a GSM phone! Lucky :) I've noticed a similar issue on various roms I've tried on my CDMA Nexus. I assume it's a loading issue: Google Now is trying to spin up, but it is unable to do so before it hits a timeout. –  fairct Jul 23 '12 at 13:35
add comment

I have noticed that it only worked when I have English US selected in the (Choose input method), all others didn't work for me, I live in Canada. English in Canada didn't work also having it set on automatic didn't work either. thanks

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.