Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Ever since I got my android, and switched to sprint, when I use Firefox, all of the images loaded are just horrible in quality, like almost to a point you can barely tell what it is.

I hear that it has to do with the data provider, routing traffic through a proxy that modifies the HTTP header with some Javascript that compresses the images to preserve bandwidth.

EDIT: I found the script. Used on EVERY page that is loaded, in the title:

<script src="http://1.2.3.4/bmi-int-js/bmi.js?version=1332944399" 
        language="javascript"></script>

This is what I need to figure out how to block!

When I hover my mouse over an image, it says "Shift+R improves the quality of this image, Shift+A improves the quality of all images on this page". So I try that and even that wont work for me.

I wouldnt mind this if I could take care of the situation when I needed to by pressing those keyboard shortcuts (Shift+A/Shift+R) but since it doesnt work for me, I am kind of stuck on what I should do about it..

Is there anyway to get around this? or a way I can fix the keyboard shortcuts to actually work?

Im a web developer so I kind of need my images to render correctly as I need to actually preview my layout and see if my pages are rendering satisfactory, but I can't do that if my images look like junk all the time.

This happens on every page by the way, but I noticed it only happens to images that are embedded using the image tag <img src=""></img>, and it doesn't happen to images loaded via CSS. .image { background-image: src="", etc; }.

Also I noticed the shortcut keys work on Firefox on Ubuntu 12.04 (just barely), but it is not working for me now in Windows 7.

So is there a way I could go into the about:config and change some values to prevent this? or a counter script, or ever something on my phone that will prevent this?

Any thoughts on this would be great, I would really greatly appreciate it. I mean its a nice feature, saves on bandwidth and all, but Its ridiculous just how bad the image quality can be, pixelated as can be, without a way to fix it.

share|improve this question
    
Aha, I found a trick for those experiencing this issue, either now or in the future. On my Windows 7 set up, pressing "Ctrl+F5" worked great to make the image quality perfect! Thank god. So even though the "Shift+R/A" didnt work, "Ctrl+F5" did. So thats a quick solution here. Also this works for all browsers apparently. But this does not mean this is the answer folks, I would still like an opinion. I would like to be able to turn off this feature if possible, and if not maybe prevent it. –  insomnia Jul 23 '12 at 16:18
1  
I've had this issue in the past tethering my company Blackberry to a Windows laptop. We rang the phone company and got them to remove this "feature" from certain numbers on our contract, apparently they add it to stop you accidentally racking up large data charges and (our provider) was happy to remove it if we we said we'd take the risk (your network may be more or less helpful, particularly on a consumer account). –  GAThrawn Jul 23 '12 at 16:31
    
Ah I see. Yeah probably wont happen with me. Im a bit of a data hog at times.. But I found the script that is used, which I updated in my original post. –  insomnia Jul 23 '12 at 16:45
    
I don't think this is an Android question –  Lie Ryan Jul 23 '12 at 18:51
    
It started as a question about my Android phone, so its an android question. –  insomnia Jul 23 '12 at 19:17

4 Answers 4

Would the same thing happen if you used a VPN? Your ISP wouldn't be able to compress images if it didn't know what the traffic was, right?

I found setting up a basic VPN to be pretty easy; if you have a Win 7 PC with an internet connection (or a willing buddy with one) you can set up a quick VPN using this guide: How to Configure your Computer to Accept Incoming VPN Connections in Windows 7. With that working, try connecting to your VPN both from your tethered laptop and from the Android phone itself. If it works you could investigate a more permanent VPN solution.

share|improve this answer

you can perhaps run NoScript (Firefox plugin) and put the IP address as the only thing in the block list.

share|improve this answer
    
I tried that, but not seeming to fix it unfortunately. It actually is changing IP's each time one is blocked. I also blocked it with AdBlock, and its getting a ton of hits but still not working. I just wish I could turn it off as a feature in my Devices network settings.. But I guess this one is done for. Dont think there is going to be an answer, as I searched far and wide on the net, and many have this problem, but all have been unpreventable unfortunately.. Lame. –  insomnia Jul 23 '12 at 19:20

In firefox get add on "Modify Header" then go to extensions then go to Modify Headers click on options and add Cache-Control then no-cache.

share|improve this answer
    
Perhaps an explanation why this fixes it would be helpful. –  Richard Borcsik Aug 15 '12 at 12:20

Try pointing your web browser at 1.2.3.50 you MAY be able to turn off image compression or use adblock for firefox/chrome to blacklist the bmi.js file?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.