Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I've got a Nexus S phone. It was never rooted or modified. It currently runs the most recent version of Ice Cream Sandwich (that was installed as an Over The Air update, without any issues).

Couple of days ago I received a notification from my phone about Jelly Bean upgrade being available. Unfortunately every time I try to install it there is a problem. The phone reboots and starts the upgrade process, but after about 30 seconds it stops and displays an image of a red triangle with an exclamation mark. When I press power+volume up to see what happened, this is the message it displays:

Finding update package...

Opening update package...

Verifying update package...

Verifying current system...

assert failed: apply_patch_check("/system/etc/gps.conf", "[random letters and numbers - probably a hash]", "[different combination of random letters and numbers]")

E:Error in /cache/9ZGgDXDi.zip

(Status 7)

Installation Aborted.

I tried "wipe data / factory reset" and "wipe cache partitions" options, but the issue persists.

share|improve this question
    
I bought the Nexus S last year in November with 2.3.6. Two weeks later it was updated to 4.0.3, the next update was 4.0.4 sometime in June and finally to 4.1.1 last week, without the error you described. –  ott-- Jul 26 '12 at 14:48
    
Yeah, I do realize most people don't have this problem. The question is what do I do now... –  Ludwik Trammer Jul 26 '12 at 16:32
    
Had you applied any GPS patch earlier? –  roxan Jul 27 '12 at 3:39
    
Have you already contacted Google's spport? Is the system still working with ICS tho? –  ott-- Jul 27 '12 at 9:14
1  
Might be worth a shot in getting a flashable zip to install the gps.conf file into /system/etc? it could be corrupted and thus the patching of it failed –  t0mm13b Jul 27 '12 at 23:50

2 Answers 2

This looks like the file didn't download properly. Are downloading the file over wifi or mobile network?

If over mobile network, try wifi, and if wifi try mobile network.

It looks like the file is corrupt and cannot be flashed - try opening the file on your computer or by using a file manager on your device.

You can also try and use desktop update software.

share|improve this answer
    
I downloaded the package multiple times. It seems to me the error message doesn't point to a problem with a update package (the "Verifying update package..." phase went ok), but with a file on my current system (the problem happens during the "Verifying current system..." phase). What do you mean by "desktop update software"? –  Ludwik Trammer Jul 28 '12 at 11:10
up vote 3 down vote accepted

Hurrey!

After quite a bit of research I am now able to answer my own question. I was able to clean install Jelly Bean (in opposite to the usual method of upgrading) using official images posted by Google. This obviously solved the issue.

Here are my instructions how to do this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.