Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I bought a Motorola Droid A855. I don't have a verizon plan, but i was going to use it on Wi-Fi only. I turned off the phone radio, I also turned the Airplane Mode on. After I turned the Wi-Fi on. It showed that I'm connected, but I can't go on the web or anything requiring Wi-Fi. I tried going into the market and it said I don't have a data connection, but I don't need one since I'm using Wi-Fi. So, if anyone has any tips pleae help.

share|improve this question
    
1st switch to airplane mode (shuts everything down), then re-enable wifi. –  ce4 Aug 13 '12 at 20:46
add comment

2 Answers

Wi-Fi won't work if Airplane Mode is on.

This is because Airplane Mode disables ALL wireless communications, for use on a plane.

On Stock ROM's, Airplane Mode also disables the FM Radio.

Solution:

Turn Airplane Mode off.

share|improve this answer
    
Funny. On my Droid2 as well as on my HTC buzz it works fine the way the OP describes it: 1) turn Airplane mode on, then 2) turn Wifi on. Of course it won't work the other way round, as turning Airplane mode on would include switching Wifi off. But once in Airplane mode, I can activate parts (here: Wifi) just fine, while all others stay off until explicitly activated (or Airplane mode turned off again). –  Izzy Jul 29 '12 at 16:14
add comment

Many phones will show Wi-Fi as connected, but won't work unless Airplane Mode is turned off.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.