Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Occasionally my Nexus 7 will exhibit poor touch responsiveness. This manifests as a need to drag my finger for an inch or so before scrolling happens, and a need for a firm touch in order to register a tap, and even then it's sporadic.

I'm trying to determine if this is software or hardware. My guess is software: exiting the current app sometimes seems to resolve the issue. Putting it to sleep and re-awakening it often seems to resolve it.

This happens maybe once every day or two, and only tends to last for a few minutes when it happens. (I'm still uncertain if things I do fix it or if it abates on its own...)

As this is my first Android device, I don't have anything to compare it to. Has anybody else experienced this? Any good techniques to determine if it's hardware or software?

EDIT 30-OCT-2012:

I haven't experienced the problem since upgrading to 4.1.2, so I'm inclined to think it was a software problem that's been fixed.

share|improve this question

4 Answers 4

up vote 5 down vote accepted

You can try to diagnose the problem yourself, or at least get a little more info by turning on a couple of developer diagnostics.

  1. In Settings, scroll down to Developer Options.
  2. Under the "Input" section, check "Show touches". This will cause a small (white) circle to show on the screen where ever you touch it. If you don't see the circle (which might be under your finger, so look carefully), you know it didn't register your touch. If you see the circle lagging, then you know it registered your touch and is just being slow for other reasons.
  3. Under "Monitoring", you may want to turn on "Show CPU Usage" and "Strict mode enabled."
    • "Show CPU usage" will show you what is running as a little overlay in the top right of the screen. The top line of the display shows the system cpu load. See this excellent write up of what the load numbers mean. If the load is high, your little Nexus-7
    • "Strict mode enabled" will "Flash screen when apps do long operations on the main thread." If your screen flashes, then you know something is hogging the CPU.
share|improve this answer
    
Thanks; those are good diagnostic tips. It's pretty sporadic, so I'm not sure if I can abide the more invasive options (like flashing the screen) for long, but at least the CPU monitor would be good to keep on for a bit. –  Aron Aug 4 '12 at 4:36

Its hard to tell if it's infact hardware or software. Since it's happening at certain intervals my guess is hardware. If it's happening with a certain 3rd party application you should have nothing to worry about. Also, have you upgraded the latest version of Jelly Bean? If so and the problem is still persisting I would recommend returning it and getting a replacement as I have never encountered any issue with touch sensitivity.

The nexus 7's capacitive touch screen is supposed to be incredible sensitive as just by meerely touching it should register a tap.

share|improve this answer
    
I have upgraded to 4.1.1 (from day 1), so the problem has happened on the latest version. Normally the touch responsiveness is quite good; it's just on the rare occasion that there's a problem. Thanks for the data point; my main goal is to figure out if it's a hardware problem before the warranty period is up. –  Aron Aug 4 '12 at 4:37

I've had that problem too. I've just power cycled the device, which always fixes it, which leads me to believe it is software. I have it set to show touches, and it would either not show the touches, or they would show up after a delay.

To determine if it is software, look to see if it happens at roughly the same time everyday, or after running specific software, then it is most likely software related. I've turned on "Show CPU Usage", which is only mildly invasive, and should be sufficient to show if CPU utilization spikes when responsiveness issues come up.

share|improve this answer

Mine started the same way until one day the touch screen would not respond at all. The buttons worked but that was it! I could not do a thing. I believe one of my pets ( a heavy cat) who to my horror loves to lie on top of warm things may have done something to the sensors.

That is just my speculation. Since it was only 4 months old, I was able to get an RMA from ASUS and got it back with all it's software and data intact in 3/4 weeks. The only thing is that they make you pay for the shipping which I find a bit cheesy but it wasn't much.

I hope yours is still under the one year warranty.

If not I would open it up (there are videos on youtube) and try to see if something came loose.

Good luck.

share|improve this answer
    
This isn't really a solid answer, and the OP says that the problem has been fixed by a software update. –  Peanut Jan 9 '13 at 20:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.