Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have 2 ZTE Blades (with 512 Mb RAM) and CM7 2.3.7 (Kang) from BurgerZ ROM installed on them.

One of them - my girl's - can connect to home and other (public i.e. McDonalds) wifi AP's even if it's signal is just one bar (it's about 6-7 meters from home router and there are two perpendicular walls on the way). But my can't do that even if 4 bars. (Also, if it can help, same situation with the gps fixes.)

I wondering why two same devices have such different behavior?

I heard that there are some patch or something to allow android to connect to wifi AP with weak signal but can't find this solution. I know thac ICS have an option Avoid poor connections but I'm not on ICS and don't want to flash it on my Blade.

Please, if you have any information or solution about that, help me to fix my device.

share|improve this question
    
I believe that option was there even before ICS. Is the one that can connect the one running CM7? –  SaintWacko Aug 6 '12 at 21:28
    
Both of them have identical rom flashed (cm-7.2.0-RC1-Blade-KANG-13APR). Both devices was bought in one time in one place. –  Крайст Aug 7 '12 at 11:21
    
Oh, I see. I misread the first sentence. Have you tried doing a factory reset on the one with the wifi issues? (Note that doing so will wipe all your data, so do a backup first) –  SaintWacko Aug 7 '12 at 15:20
    
Do both devices have the same radio? –  Michael Hampton Aug 10 '12 at 19:52
    
@Michael Hampton, Is radio hardware or software part and where can I check if they're the same or not? –  Крайст Aug 11 '12 at 10:07
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.