Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My rooted Galaxy Nexus is on Jelly Bean (4.1.1) with a super user application. I want to install sinhala font into the phone, and for that I've tried to copy the font file (droidfallbackcens.ttf) to the font folder in my phone using the root explorer app. But it says that I have only read permissions on my phone.

I have googled this issue and tried several methods (most of those methods were about ICS), but I haven't been able to change file permissions to get "read write execute", can anyone help me with this?

share|improve this question

You may need to remount your file system to enable write. I'm not sure how that's done with Root Explorer, but from the Terminal it looks something like:

mount -o rw,remount /partition/name/

You can get the partition name by typing mount without any parameters.

share|improve this answer

If you are using the Speed Software Root Explorer application then you might be holding your phone wrong! -guffaws

No really! When I hold the phone in portrait view I can't get access to the little button in the interface that puts that directory into R/W mode (Read/Write):

Portrait view, no button

Hold your phone in landscape view when you navigate to that folder. When you get there you will see the little button to 'Mount R/W':

Landscape view, button present

Remember to turn it back to 'Mount R/O' (Read/Only)

If this doesn't fix your issue then I will wonder if you actually have root access. Just saying...

Good luck (:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.