Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Is there any J2ME emulator like JBed for ICS? I've found a ton of tutorials like this but as far as I know, all of them are exclusively for Gingerbread and below.

P.S. I already tried J2ME Runner but whenever I submit my JAR and JAD files for conversion on their site, it would hang up and send me a converted .APK with corrupted content so that cancels out that method too.

share|improve this question
    
Think this should belong on StackOverflow –  t0mm13b Aug 11 '12 at 13:34
8  
How so? This isn't programming-related. I believe it's an end-user question since I'm wanting to run old Java games from my Nokia phone on my Android phone. –  Propeller Aug 11 '12 at 13:36
    
Are you sure you get corrupted content? Do you have the J2ME Runner inside your phone? –  Secko Oct 10 '12 at 16:10

3 Answers 3

J2me Runner Netmite has probably fixed their website and since then no corrupted files have come out. I just made a UC browser cloud version from them and it works on Jelly Bean, however there's problems; the internet connection is not establishing at all, and the original apk app runner doesn't open at all. (there are two Apps in one apk.. the App Explorer opens with UC web. but the original app doesn't open)

The error log is specific: permissions denied: Android. intent. broadcast. action. PROXY_CHANGE from pid****uid*****

From what I see, Android security systems changed to block this intent. I tried converting it to system app, but no use.I think you have to run as root.. not sure how though.

Update: Sorry, it looks like it was my firewall blocking it, and I've fixed the issue. UC Web is running fully on my HTC A310E (CyanogenMod) and it's much better than JBED.

share|improve this answer

With Android's Gingerbread builds, it was built using the Java 1.4 components, ICS and later are built using Java 1.5+.

Nokia uses Symbian specific Java midlets and JAR's written using Java 1.2 or 1.3 ME edition.

And from the tutorial linky, there is no mention of specifically running Nokia's apps on it.

Rather, the impression I get, is Java agnostic JAD/JARs/Midlets not tied to any platform.

In your case, Nokia apps are specifically for Nokia which I guess is why it failed.

share|improve this answer
    
I've also tried a Java game that ran quite well on a Samsung Corby 2 so I doubt that that's the case. I'm convinced that the problem I'm having is because of the lack of ICS support though. :( –  Propeller Aug 11 '12 at 19:06

There is a working one called phoneME. It was written for Android 2.1-2.2, so don't expect it to be stable. Here's download link:

http://davy.preuveneers.be/phoneme/?q=node/10

Also, emulator doesn't appear to like paths with spaces and to run JAR files directly, so you need to make a JAD file. Sorry for my bad English.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.