Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed DroidID3Tagger, however it just searches for my music files in /mnt/sdcard, my music however is in /mnt/emmc.

Is there anything I can do instead of moving the files?

I'm using CM9 Nightly on a SGS1 with Icy Glitch Kernel. (for some reason the Kernel swapped sdcard and emmc)

share|improve this question
up vote 2 down vote accepted

In response to @Zuul's comment below his answer, usage of the ln -sf /mnt/emmc /mnt/sdcard is not the appropriate way of dealing with it, because it's a soft-link and forcing it that way, can lead to some mis-behaviour of apps who are relying on the SDCard's mount point, by way of refusing to work with it, Play Store can fail in this regard.

The best solution is to use this:

By using busybox, explicitly bind the mount point to make /mnt/emmc behave exactly like a SDCard, i.e:

/system/xbin/busybox mount -o bind /mnt/emmc /mnt/sdcard

Which will show up as a mount point in the proper way, if this was a soft-link it would end up like this -

/mnt/sdcard -> /mnt/emmc

Google Play store, as I mentioned has an internal checking mechanism to see if the directory is not a link (it will return a error of -22 IIRC).

share|improve this answer

This app reads files from the device internal storage located at /mnt/sdcard, not from the external storage or any other location.

Since the app was last updated on March 4 2011, I don't think this will get fixed.

However, if you have root on your device, you can create a soft link from one location to another thus tricking the app.

The command is used like this:

ln -sf {target-filename} {symbolic-filename}

So you should execute:

ln -sf /mnt/emmc /mnt/sdcard 

When the app accesses the /mnt/sdcard the system will give it the contents of /mnt/emmc.

share|improve this answer
Just for clarification it does use /mnt/sdcard, but in my case it's my external SD. /mnt/emmc is my internal SD. (Something got messed up when I installed the Icy Glitch Kernel) I tried this code in "Virtual Terminal", i get the error message "link failed No such file or directory". – silent_cookie Aug 13 '12 at 21:36
hmmm... maybe ln is not the appropriate way to deal with it - perhaps using busybox as in /system/xbin/busybox mount -o bind /mnt/emmc /mnt/sdcard ? – t0mm13b Aug 17 '12 at 21:36
Yes, that worked ;) I don't use the app anymore but it might come in handy on other things aswell – silent_cookie Aug 23 '12 at 19:46
@wayback What end up solving the issue, the soft link or the mount? – Zuul Aug 23 '12 at 19:48
@Zuul The busybox/mount solved it – silent_cookie Aug 23 '12 at 19:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.