Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ever since the 2.2 update, I'm receiving multiple Gmail notifications without accessing the Gmail app and with the setting "Notify only once" active.

I've tried a factory reset, but it still does this.

Any thoughts? I do have my Gmail auto-popping another account, could this be it?

share|improve this question
Are you being notified multiple times for only a single email or notified for additional emails? – ryanklee Nov 11 '10 at 15:14
Notified for additional e-mails. In Gmail under Notification Settings there is an option called "Notify once" and I have it checked. – chrispt Nov 11 '10 at 17:09
Are you sure one of the emails isn't from another email client? – gary Dec 11 '10 at 17:16
I have one account setup (my primary). I also only use the Gmail app. Perhaps I don't follow. – chrispt Jan 3 '11 at 17:17
Have you ever solved this? Did you tried to lose the other account you've mentioned, to see if the issue was caused by it? – Zuul Sep 4 '12 at 17:14

It sounds like maybe you added your GMail account to the regular Mail app. So you are probably receiving notifications from both apps.

If you are only using the "GMail" app then find the "Mail" (not "GMail") app in your app drawer and run it and see if your mail is in there too. If it is just delete the account from there and then you should only get notifications from GMail not Mail.

share|improve this answer
I admit that I initially fell into this confusion. I didn't realize that the gmail app is pre-installed and separate from the mail client. The two envelope icons befuddled me for some time... – Brett Feb 10 '11 at 17:32
I only have my Gmail configured under the Gmail app. It has never been setup under the Mail app. – chrispt Feb 16 '11 at 17:14

I got a new phone and this issue seemed to resolve itself. Not sure why it was doing it before, but it's not doing it now.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.