Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't access the internal SD Card (8GB) on my Wayteq x-tab 80, with Android 4. The device is not rooted, and worked perfectly fine until yesterday. I could access the SD card from the tablet, and also from my PC when connected with USB. Now it doesn't work either way. I checked in the Settings, and it seems like the SD Card is Unmounted, but even after clicking on Mount it doesn't do anything. I did a factory reboot, it didn't help.

I'm not a tech expert, so I can't figure out what's the problem. Any ideas?

share|improve this question
Just to rule out human errors due to panic, could you try downloading some file? If you can then your device's internal storage is intact and system is able to access. May be it will throw some light on what else could be wrong. – Narayanan Aug 20 '12 at 10:15
Has the SD card been removed at all during this time? Are you able to try the SD card in a different device to make sure it's not at fault? – w3dk Aug 20 '12 at 10:26
I tried to download files, it says that "an SD card is required to download [file name]" – pansy0 Aug 20 '12 at 10:30
It's an internal SD card, so no, it hasn't been removed. The tablet is only 2 weeks old so I would rather not try to remove it, also I have no other device to put it in. – pansy0 Aug 20 '12 at 10:35
This is not a solution to your question, but a way to keep your device working till you get it repaired. Buy another micro SD card and insert into the device slot. This will make the device to start using the new card as its storage and you will be able to start using the tablet. – Narayanan Aug 20 '12 at 10:44

You can use these 2 recovery softwares to recover data from a damaged partition table if this is the case:

share|improve this answer

Maybe the Media device (MTP) option is disabled. Make sure that this is enabled, you would find this under the menu option "USB computer connection" in Settings > Device > Storage. Also make sure that "USB debugging" is disabled in Settings > System > Developer options.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.