Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I am able to run Ubuntu in chroot environment on my Asus Slider sl101 (cousin of the original tf101 asus eee pad transformer).

But, for various reasons I would like to be able to actually boot into Ubuntu or Android at will.

I am currently running Cyanogenmod 9 ICS and have the device rooted.

Another thing to note is that any attempt in the past to use NVflash ... seems to fail
On top of that NVflash ubuntu dual boot instructions are usually fairly ... vague.

Being a Linux user, ideally I would LOVE it and be in complete bliss if I could choose to login to android the same way I can choose to login to Gnome or Unity or XBMC etc... login to an Android session and just have the option of logging into Unity or Android....

Since Android is really more like a Java runtime environment, it would be ideal to just have Ubuntu as main and just be able to start up the Android runtime environment whenever I needed... But I am not able to do this kind of thing with my limited knowledge and do not understand what the raodblocks are.

That being said, anyone know how to get my sl101 dual booting ubuntu?


UPDATE 20120821

i found a couple instructions that look very promising.

These sights may go down in the future but I will be sure to post detailed instructions if they are successful.

http://forum.xda-developers.com/showthread.php?t=1537566

http://forum.xda-developers.com/showpost.php?p=23428126&postcount=3

I will be trying the files for both sites.


UPDATE 20120823

I've had a few CRIPLING problems so far.

1) the android.zip file from one site works but the one from the other site does not. Be sure to get the android.zip file associated with your ROM that you are using. In my case , I'm using CM9 RC2 so I had to use the CM9 android.zip file found here:

http://www.mediafire.com/?labcx60jowrdx

or if that server is down in the future you might try to find it from this site again:
http://www.mediafire.com/?labcx60jowrdx

2) the ubuntu.zip file works from the oposite site but the one from the other site does not. The one that does not work is called ubuntu-31patch.zip and it was made to flash a more up to date kernel and 3.1.10 kernel modules were also provided but this zip does not work for some reason and I can't figure out why. The one that works for me is here 2.6.24.4 i think is the kernel version number:

http://dl.dropbox.com/u/60048492/transformer/Ubuntu-mountloop.zip

if that does not work, you might find a new link here:
http://forum.xda-developers.com/showthread.php?t=1537566

3) The sl101 sliding keyboard does not work but if you plug in an external usb keyboard, the usb keyboard will work. no idea how to get around this problem but .... having the sl101 is useless if the sliding keyboard can't get working. How lame to have to carry around a usb keyboard when there is one attached already ... really want to get this working.

4) wireless internet does not work. I assume that is part of what the 3.1.10 patch was for but the patch doesn't work so I'm still working on this.


UPDATE 20120824

Finally got the android-mount.zip file working. I switched the kernelblob with the one that works with my wifi on cyanogenmod 9 and it works like a charm now. In fact, if you have wireless issues with your sl101 or tf101 you might just flash the zip file I made it it might fix them...

I'll make the file available with the answer but still trying to get the sliding keyboard working under ubuntu.

This is what happens when trying to use the ubuntu31.zip the file that boots ubuntu with 3.1.10 kernel

This is what happens when trying to use the ubuntu31.zip the file that boots ubuntu with 3.1.10 kernel

these are random errors with the kernel 2.6.36.4 ubuntu-mount.zip file. i wish i understood

these are random errors with the kernel 2.6.36.4 ubuntu-mount.zip file. i wish i understood

this too

share|improve this question
1  
Please do! And best put them into an answer then (yes, you can answer your own question and even accepting it) -- which helps others to see straight from the list (e.g. search results) there is a solution included. –  Izzy Aug 20 '12 at 18:00
1  
I know. I will put it all into an answer when I find the answer and get it working. I don't consider what I have done so far a working answer though... hyet. –  Joshua Robison Aug 22 '12 at 16:30
    
got it working but the keyboard still doesn't work... usb keyboards work fine. makes no sense –  Joshua Robison Aug 27 '12 at 11:44
    
Let me get this right - you are using boots ubuntu with 3.1.10 kernel, a 3.1.x kernel, yet these are random errors with the kernel 2.6.36.4 ubuntu-mount.zip file Are you mixing up the kernel modules from one to the other as they are not compatible! –  t0mm13b Feb 10 '13 at 19:41
add comment

1 Answer

Think i found the answer, there's no ramdisk in the blob from the 3.1 patch.. not sure if that's needed or not.. or if we're supposed to patch on top of the 2.6.24.4 kernel, basically i unblobbed it and found just a zImage, the 2.6.24.4 blob has both zImage and a ramfs..

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.