Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I don't know why but the Wi-fi on my Droid (Froyo) keeps auto-enabling. I can't figure out what is causing it and want to make it stop. I only like being connected to wi-fi at times of actual use so I don't waste battery.

Anybody think of applications/settings that can be configured to auto-enable wi-fi?

share|improve this question
    
I have found the culprit but I still don't know where to look to change the settings, these things get enabled when I used my desk dock. –  cynicaljoy Nov 18 '10 at 15:21

5 Answers 5

What about rebooting your device ?

I had the same problem solved like this...

[EDIT] Do you use a widget for the wifi: it can help you to disable it?

share|improve this answer
    
rebooting fixes sooooo many problems. –  Michael Paulukonis Nov 12 '10 at 12:03
    
I wish I knew how to recreate this issue rather than just a generic 'it happens sometimes', would make troubleshooting this issue a lot easier. –  cynicaljoy Nov 12 '10 at 15:52
    
does rebooting fixes your problem ? –  Pascal Qyy Nov 12 '10 at 21:22
    
no, rebooting has not solved the issue –  cynicaljoy Nov 16 '10 at 15:31

There could be any number of apps that re-enable wifi: can you share your appbrain app-list? It would be easier for us to tell.

share|improve this answer
    
    
Juice-defender, Ultimate Juice, Power Manager Full -- one of these is likely to be the culprit. I can't speak from direct experience, because I've intentionally avoided these apps, but the general sentiment is that they are a bad idea, because they lead to odd phenomena such as you are experiencing. I'm not saying that they are always a bad idea, or that they can't be used without ill-effect, but they do tend to monkey with processes that are better controlled by other means. You might want to try without them for a bit, see if it solves the issue. –  ryanklee Nov 12 '10 at 17:21
    
I've disabled (uninstalled) those applications and will attempt to run without for a few days. Will update with results. –  cynicaljoy Nov 16 '10 at 15:34

What do you mean by auto enabling? Does it get enabled every time you unlock your phone? Otherwise did you try changing this option: Settings->Wireless and Networks-> Wi-Fi settings (press menu key) Advanced -> Wi-Fi sleep policy

(I have Android 2.1, so your menu path may differ slightly)

share|improve this answer
    
Auto enable meaning that I manually disable the wi-fi and the device turns it back on without my specific direction. This wouldn't be the sleep policy as that would be what turns it off. Thanks for the suggestion. –  cynicaljoy Nov 12 '10 at 15:49
up vote 0 down vote accepted

Look for an application titled 'Power Manager', this application has controls to enable/disable: WIFI, Bluetooth, GPS based off multiple triggers. One of which being powered by A/C which was what my 'issue' was. Just had to change this so it didn't change the WiFi status.

share|improve this answer

If you have Sprint, go to Settings → Wireless and Network/More... → Mobile Networks and uncheck the box Connections optimizer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.