Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

Am running 4.1.1 on a GSM Galaxy Nexus and continue to have very poor connectivity issues with Wi-Fi (everywhere, not just in my house). Other than having an unlocked bootloader and being rooted, the device is stock.

My AP in the house is running on Channel 1, and there's no other WiFi that's close to my house. No RF interference to speak of (e.g. no microwave's running or 2.4ghz FH devices in vicinity). Right now I am not so close to the AP, but have good signal strength on my device: -65dBm. The AP is a Linksys WAP54g with the latest firmware available running WPA2 Personal AES. The device may eventually connect, but often it just hangs on "connecting." I've tried to change to WPA2 "mixed" (AES+TKIP) but that doesn't seem to have any impact (still hangs on negotiating). I would just chalk this up to a Linksys issue, but I have had same issues out in public Wi-Fi.

I was using Wi-Fi Analyzer to manage the connection, and didn't see the message regarding "Poor Internet Connection" and reason for failure. I changed the Advanced Wi-Fi option to deselect that option, and rebooted the device, and then connected OK.

I have a Nexus 7 on same network with no issues (the UI has no option for "Avoid Poor Internet").

share|improve this question
1  
Strongly recommend looking at: android.stackexchange.com/questions/29291/… –  david6 Oct 2 '12 at 9:03

1 Answer 1

I had the same issue with my galaxy note 2 after upgrade to 4.1.2. No wifi worked after the upgrade reboot. After lots of trial and error I found that the only wifi working consistently was wep/psk/tkip. No protocol using aes encryption worked - merely "obtaining ip address". This doesn't solve the problem, merely a temporary workaround. Good luck.

Forgot to mention that the wep/psk/tkip must be set on your router. Power cycle your phone and reenter your password when the phone attempts to connect. Also I found that turning off power saving mode on the phone also is required. Go to phone dialer and enter *#0011# to enter phone command mode. Select menu options and click Wifi option. Turn off power saving mode. Power saving mode = ON is default so must be changed after every power cycle.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.