Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I did it using Gingerbread (Samsung Galaxy Ace 2), but with Ice Cream Sandwich (LG L5) I don't see appropriate action for that.

Previously I entered Contacts (ok), then selected Settings (ok), executed Google Merge (no such option), and Sync Data (disabled all the time).

I see only one available (not disabled) item that is relevant -- configuring sync option for my account, but I understand it will work non-stop, and I want action on demand, just from time to time, when I explicitly select it, not enabling a background sync process.

What also worries me, that in GB I could choose where to store contacts (phone, SIM, google), in ICS after initial import from SIM card to phone, I cannot choose anything.

UPDATE -- (hardcore) WORKAROUND

I found that for given single contact I can switch its type from phone to google, nice, but it does not solve the problem due to the amount of contacts.

UPDATE -- DON'T DO THIS

I tried to somehow do it automatically, so I did (but you don't):

  1. change the mode of sending vcard to single file
  2. share contacts
  3. select all
  4. type: gmail
  5. recipient -- yourself
  6. send
  7. OK, switch to gmail app
  8. open the attachment with contacts
  9. choose target as google account
  10. all contacts will be merged with existing ones, but now as google ones

And the last step is killing this workaround. Why? Because some contacts will be added (so when you had "A" you will have "A" for phone and "A" for google), the others will be joined (so when you had "A" you will have "A" as before, but now with double type -- phone and google). In short -- the result is mess. Now I have more work to do than manually switching one by one type of the contacts. Geee, progress, right? ;-/

share|improve this question

3 Answers 3

If you want to "sync on demand only": Just enable sync at the time of demand for, say, 10 minutes while connected to your local Wifi -- and then disable it again. Enough time for the service to get its job done. You can do so in "Accounts & Sync"1, after chosing your Google account:

Settings Sync

If next to "Sync contacts" you see the same circular symbol as the screenshot2 shows next to Sync Google Reader, you probably do not even need to activate the permanent sync, but simply hit it for a one-time "sync on demand".

share|improve this answer
    
Thank you, I had the state with and without such icon, also similar icon appeared in notification area for two seconds, and then disappeared, however no contacts were sent (I logged in, to the google account to check it). Also still all contacts are "phone" contacts, and they should switch to google ones (I believe). Please see update section -- now I think, that in ICS only google contacts are synced, and the phone ones are ignored. So it might be the question how to convert phone contacts into google ones. –  greenoldman Aug 30 '12 at 16:06
    
Oh -- as long as they are "phone contacts" (as opposed to "google contacts"), they won't sync this way. In this case you might want to check How to move phone contacts to Google? first -- or, if you'd rather not sync them with Google, check for an alternative to sync with (on Windows, this could possibly be MyPhoneExplorer -- but as non-Windows-user I cannot tell for sure). –  Izzy Aug 30 '12 at 16:10
    
Thank you, the post you linked is old, it is for 2.1, and as I said I am asking about ICS (4.0). Once again, in 2.3 the syncing was straightforward, all needed options were right on the screen. –  greenoldman Aug 30 '12 at 16:20
    
I could not check with ICS (have no device with 4.x), but it at least still works with GB (2.3.x), so I thought it should be still valid for 4.x as well. Does the contacts app in 4.x no longer offer the export/import functionality? –  Izzy Aug 30 '12 at 17:41
    
Yes, there is, but it is for transferring data from/to phone from/to SIM card. –  greenoldman Aug 30 '12 at 21:19

Another approach summarized from macias' experiments plus all the comments accumulated so far, is to follow these steps:

BE AWARE THAT THIS HAS YET TO BE APPROVED OF, AS IT WAS NOT TESTED!
I still chose to already add this here, as otherwise it would be hard to follow through all the comments to figure this out. Compared with what macias already did, steps 7-9 have been added/inserted to (hopefully) prevent the mess it caused for him.

  1. change the mode of sending vcard to single file
  2. share contacts
  3. select all
  4. type: gmail
  5. recipient -- yourself
  6. send
  7. open the GMail web site with your account
  8. optional: export/backup all contacts again from here (unless you use a new/empty separate GMail account, as the following was not yet tested)
  9. purge all contact data from the webapp and your devices
  10. OK, switch to gmail app
  11. open the attachment with contacts
  12. choose target as google account
  13. all contacts will be added, but now as google ones

Compare with the steps described in the question's update to see the difference and what has gone wrong there. It should work this way, but that yet has to be approved of. If somebody can verify this, please say so in a comment -- and I will update this accordingly.

share|improve this answer

I have a HTC Sensation running ICS.

I had been looking to do this, read around a little then in playing with my phone, seem to have done it with a selection in the menu in 'People'.

For me there was simply a 'Move Contacts' in the Main menu in 'People'.

  1. A box pops up, "Move contacts from" with choice of 'Google (qty of contacts)', and 'Phone (###)'.
  2. I touched 'Phone...', it presents a box, "Move contacts to" with one choice 'Google (###)'...
  3. Touch 'Google', and it asks, 'Confirm moving' "Are you sure...?" - Cancel-OK.

Process begins, and is not particularly fast - visibly one at a time...

Interestingly however, it didn't 'Move' my contacts but rather 'Copied' them - they are all still in the Phone, but now all in Google as well.

Not too bad as I can now either filter the list to not display the Phone ones, or delete them all off the phone as they are now all in Google.

...now just a matter of going through and de-duplicating.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.