Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have a Motorola Milestone, and sometimes when I press Home to go back to the Home Screen, the screen shows no application icons, no widgets.

It simply stays blank, with the wallpaper on background. I can navigate to the other Home Screens by dragging to left or right, but every screen it empty.

The phone seems normal, no slowness, the app drawer opens up normally.

The only solution I thought was to restart the phone. I don't use any task killer.

I also noticed this started to happen recently, after installing many applications. And it normally happens after running some heavy app, like Angry Birds.

Did anyone notice this too?

share|improve this question
2  
Just FYI: the program that shows your homescreen (dashboard) and all the icons and widgets is also your launcher. Getting an alternate launcher might help. –  Arda Xi Nov 13 '10 at 18:41
1  
Does it eventually load the icons and widgets? –  Bryan Denny Nov 13 '10 at 19:37
2  
I think your mixing some words here and some clarification may invite more responses. Correct me if I'm wrong but by "Dashboard" do you mean "Home Screen"? And by "Launcher" do you mean the "app drawer"? –  Matt Nov 13 '10 at 19:57
    
@Matt: right, those are better terms, I edited the question. –  Willian Mitsuda Nov 14 '10 at 19:44
    
@Bryan: no, I left my phone idle for several hours, and the icons didn't come back. –  Willian Mitsuda Nov 14 '10 at 19:46

2 Answers 2

The Milestone (original Motorola Droid to all you Americans) doesn't use the default home screen app because of the slide out keyboard, since the default home screen app doesn't support landscape. Switching to one of the other alternate home screen apps might solve your problem.

share|improve this answer
    
Still the same problem with LauncherPro for me. –  Firefeather Oct 4 '11 at 14:16
    
Didn't the Milestone ship with LauncherPro? Try something else. –  MBraedley Oct 4 '11 at 18:46
    
Not that I know of, at least for the U.S. version (Droid), which is what I have. Thanks –  Firefeather Oct 5 '11 at 20:27

Took me a while to figure out but it happened to me only at work. For some odd reason, when plugged into USB on Windows 7 Ultimate (to charge), this would occur. At home, I use 7 home premium and everything works - driver and software. The PC at work simply would not install the driver for the phone, and would leave my phone hanging. Being I am at work, I don't have the 'time' to troubleshoot, but do notice this occurs often. Hope this helps - from Toronto, Canada.

share|improve this answer
1  
Not sure if this should be a comment or a new question, not really sure that it's an answer. On another note, it sounds like your company's admins have blocked the central Windows Update site (presumably because they're using something like ther own WSUS server) this will stop your work PC from being able to download random drivers from the Windows Hardware catalog, and often will leave a PC sitting there waiting for a time-out when it tries to find the drivers, and will (depending on the phone make/model) often prevent USB charging. –  GAThrawn May 3 '11 at 10:07
1  
Milestone here and I get the same problem but almost never use the USB, so I don't think this is the answer. Might be a catalyst for some other problem. –  Aaronaught Aug 20 '11 at 19:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.