Take the 2-minute tour ×
Android Enthusiasts Stack Exchange is a question and answer site for enthusiasts and power users of the Android operating system. It's 100% free, no registration required.

I have Samsung Galaxy S II with Android 4.

If I configure my phone to GSM/WCDMA (automatic) mode, I have problems when I receive or make a call. Usually I lost the call or the other person cannot hear me.

In my city 3G network is not very good.

I solve this problem changing the mode to GSM only (manually) and then make the call.

Is there a way to configure my phone to change from WCDMA to GSM automatically when I make or receive a call?

I've installed 2G/3G OFF application, but it is still manual.

share|improve this question

3 Answers 3

up vote 6 down vote accepted

If you constantly get a poor 3G signal, you may want to switch the signal preference to favor 2G instead of 3G. Here's a way to do it on ICS:

  1. In dialer, press *#*#4636#*#*
  2. Go to 'Phone Information'
  3. Swipe to this 'Set preferred network type'
  4. Assuming it is 'WCDMA preferred', change it to 'GSM Auto (PRL)'

enter image description here

This setting will change its signal quality threshold, allowing it to switch from 3G to 2G 'earlier'. Use at your own risk though...

To address your question of automatically switching signal when you make a call, you might be able to hammer something out on Tasker if you are so inclined (I may give it a try later to satisfy my own curiosity xD).

One problem is forsee though, is that I believe it takes a bit of time to switch signals, so it might affect your call (or its quality).

share|improve this answer
    
Good answer! To you have any idea what PRL stands for? –  Flow Aug 31 '12 at 7:40
1  
Thanks! PRL stands for Preferred Roaming List. –  Void Aug 31 '12 at 8:45
    
Very good! Thanks. –  Pabloker Aug 31 '12 at 15:15

I would say that the practical anwser is no. Although you could theoreticaly make an appliction/script that would swith to 2g before a cal, the script would have to wait a few seconds before making a call while the phone switches signals. This will make it no faster than manualy changing it before calling.

I suggest you put the 2g/3g widget near your dialer and press it before you enter the dialer, by the time you choose a contact the phone should be ready to call.

Another option has to do with rooting and voiding your warranty: flashing different modems(radio images) from xda. Some modems hold to signals much more aggresively (but use more battery).

The last and most obvious option (the one that I would choose in your place) is to just stay in 2g mode when in the city. Since the signal is so bad you drop calls I would guess that data speeds are slow and dropping too. You will also gain in battery life beacuse the phone won't be constantly searching and droping signals.

In any case I would consider changing the carrier if there is a better option where you live.

share|improve this answer

I think I've got the solution to your problem, rather our problem. I've been facing this issue for a couple of weeks now, during which I was not able to make any calls when my network mode is set as WCDMA or GSM/WCDMA auto.

I called up my network operator, and they were able to provide me a solution. In the call settings menu, inside Additional Settings, there is a setting for displaying the Caller ID in outgoing calls. I had changed this setting to 'Hide number', and that was the reason I wasn't able to make any calls in the WCDMA mode. After I changed it to 'Network default' or 'Show number', I was able to make calls even in the WCDMA mode. :)

Hope this helps you too.

share|improve this answer

protected by Community Dec 24 '13 at 4:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.